ffmpeg installed but can't be located

I am running the latest versions of both ffmpeg (2.2.2) and audacity (2.06) and have attempted both the dmg install and the zip file drag to both /usr/local/lib (I know this isn’t recommended but it wasn’t working and lame installed itself there and is working fine) and /Library/Application Support/audacity/libs/ for libavformat.55.dylib (it originally defaulted to .52, so I tried that as well, but still no dice). In both cases, FFmpeg library remains “not found”. Any help resolving this would be appreciated.

I am using this on a mid-2014, MBPr 13", 2.8 i5, 8gb, running 10.10 (could this last be part of the problem?).

I don’t think Audacity directly supports “San Gabriel” or whatever mountain range that is.

It says in the release notes for Audacity 2.0.6:

OS X 10.10 Yosemite: Audacity 2.0.6 will not officially support OS X 10.10 Yosemite when released (in particular, Apple Audio Units may not open in Audacity).

As Steve said, Audacity does not officially support Yosemite. But 2.0.6 recognises /Library/Application Support/audacity/libs/libavformat.55.dylib OK for me on Yosemite.

I suggest you quit Audacity, open Finder, Go > Go to Folder and type:

~/Library/Application Support/audacity/

Open the audacity.cfg settings file in TextEdit. Select all the text and delete it.

Then type the following at the top of the file:


This resets all your Audacity settings. If you only want to reset the FFmpeg path, don’t delete all the text. Just find the [FFmpeg] line and delete that line, and also delete the “Enabled” and “FFmpegLibPath” lines underneath that.

Save audacity.cfg.

Find and delete all the files on your computer starting with libav.

Reinstall FFmpeg 2.2.2 from the DMG: Audacity Manual and don’t change the installation location.

Now restart Audacity.