FFMEG lib won't install

I have Audacity 3.1.3 running on MacOS 12.2 (Monterey).
This is a new MacBook Pro, so I reinstalled Audacity.
When I tried to open an .m4a file I got an error message, so installed FFMPEG from the download page (ffmpeg.55.64bit.dylib). (I tried both .dmg and .zip versions.)
I then went to Preferences > Libraries > Locate and selected the file, but the preferences dialog still says the library is not found - even after restarting the app.
I also confirmed that the library is in the Library/Application Support/audacity/libs directory.
The attached a screen recording summary confirms this behavior.
I’m stuck…anyone able to help?
Much appreciated!
ffmpeg_not_installed.pdf (457 KB)

did you solve your problem? My guess is that you did not restart Audacity after installing the ffmpeg library file. I have a MacBook Air and have installed without any issues

I do however have a problem in that I cannot export Apple Lossless (ALAC) .mp4 files. Only option available is .mp4 (AAC).

Did you use the recommended download files from buanzo?

https://lame.buanzo.org/#lameosx64bitdl

RECOMMENDED download:ffmpeg_64bit_osx.pkg

I resolved this by deinstalling Audacity and reinstalling it, then installing the ffmpeg library before launching it for the first time. Am now able to import .m4a. Thanks for all the tips.

Hi, I’m new on the forum but have the same problem; except for one point I run Catalina 10.15.7 on my Mac mini
Is it a problem ?
Message is the same (but in French : La bibiliotheque FFmeg est absente
I do the exact process you have share…nothing change…
Thank for your help and have a nice day :slightly_smiling_face: !
Capture d’écran 2024-02-15 à 12.21.05