Few Audacity questions

I do not have a lot of experience with Audacity though I have been using it for a month or so. I have few questions I wish to ask. Currently, I run latest version 2.0.0 (unicode)

  1. why anytime I run Audacity I first get a small windows “analysis plug-in VST” checking on all plug-ins and than I get the main Audacity windows? I did not have this issue when running rel 1.3.4 (or better the previous version to 2.0.0). How to avoid this?

  2. how come I am unable to move the bar of the input level next to the microphone ? Anytime I move the mouse of it it says to use the system mixer. Is it possible or not to use it?

  3. Is there a way to turn the mouse into a small hand and move through the timeline with it? I try to ask again with an example (as difficult to explain): with Adobe Reader I can change the cursor of the mouse into a small hand and I can move inside the document with the mouse being a hand. Is something similar possible with Audacity?

Thank you,

  1. Audacity > Preferences > Effects > [ ] Rescan VST… (de-select)

  2. If you’re using a USB microphone, the volume is determined at the microphone, not the mixer or Audacity.

  3. That’s “scrubbing” (like on a video editor) and it’s a Feature Request for a future version of Audacity. While Audacity is playing, you can click anywhere in the upper timeline and Audacity will immediately start playing from that point.



  1. Audacity > Preferences > Effects > [ ] Rescan VST… (de-select)
    This is already de-selected. As a matter of fact, with previous release I did not have any issue. Rather, here I have this issue.
    I will try logging in into Windows from another user profile. I need to see if this comes from a corrupted user profile or not. Why this? Simply because it does not behave the same way on my laptop, with same OS.

Will let you know the results.

  1. the input is from my sound card Line-in from AC97 and not from my USB microphone. How do I solve this as being quite important to me? I am acquiring the sound signal from the Line-in from home stereo system.

Thank you,

Do you have any VST effects installed?

What do you have selected in the Device Toolbar?

You mean that you just want to “scroll” through the audio track? You can do that with the mouse wheel if you hold down the “shift” key.
See here for other ways of moving around a project: http://wiki.audacityteam.org/wiki/NavigationTips

Hi Steve,

Do you have any VST effects installed?

  1. After installing Audacity, I installed “LADSPA_plugins-win-0.4.15”. I do not know if I have VST effects installed. How to find out?
    I tried with another user profile but it behaves the same way.
    On my laptop, with same OS, I do not have LADSPA plugins installed and most likely this is why it does not behave the same way.

As for question n. 2 I refer to the Mixer Toolbar
I am only unable to move the hand slider of the microphone.

After doing some reading on the Audacity Online Manual, I believe I found the answer to my issue:
If the Input slider does not have direct control of your sound device’s input level, it will be disabled and set to maximum. You will need to set the recording levels using the input slider in the operating system mixer or in the sound card control panel. To locate the system mixer see the help on our Wiki for Windows, Mac OS X or Linux.

As for question 3, I thank you for this tip. I now know how to move. Still, the little hand could be useful for short horizontal movements.

Thank you,

I wish to elaborate on the second question (I am unable to move the hand slider bar of the microphone input).

Here are some settings:

Windows Mixer

Recording Settings

AC97 Settings

A screenshot when I am recoding:

This is a sample of the recordings:

=> Here are my questions:

I noticed that I am unable to control the level of the input signal directly from Audacity and from Windows Mixer, via the “Recording Mixer” even if I change its level. When I change the level it affects the audio that the PC speakers produces. The only way to modify the recoding level is from xK application (the audio driver software) as shown on second picture “Recording Settings”.

Now, Is the wave signal of my recording sample ok? What is a good average value?

Also, I noticed that I have to raise the Gain to a value of about 10 before the sound gets distorted and this in order to obtain a higher volume when recording. Is this normal?

Lastly, when someone has some answers on the Plug-in issue I wish to know if I can avoid same scanning or not.
Thank you,

Topic moved to the Windows forum.

You will only have VST effects installed if you have installed them. Audacity does not ship with any VST effects.
As you don’t know, I’d assume that you have not installed any, in which case the easiest way to prevent the unnecessary scanning is:
Edit menu > Preferences > Effects.
Deselect (disable) VST effects.
Close and restart Audacity.

Hi Steve,

what you advise me to do does not work. It just does not.
So far, comparing two PCs, I see the only difference that makes one not scan for VST plugins is “LADSPA_plugins-win-0.4.15” being installed or not.
I do not know if this makes any difference but other than that I do not see any other difference. Moreover, prior to installing ver 2.0.0 I was using ver 1.3.4 (or what was beofre available) and did not have any issue with VST plugins popping up when loading Audacity.

What to do?

What about the other questions? Hope someone can answer.

Thank you,

Regarding your problems with the KX drivers:
These are very complex and non-standard WDM drivers for sound cards that have either an EMU10K1 or EMU10K2 sound chip.
I’ve only ever used them with Windows XP so I have no idea how they will behave (or misbehave) under Windows 7.
Windows 7 is not officially supported by the KX drivers http://kxproject.lugosoft.com/faq.php?language=en#Q3

That is the same when running the Kx drivers under XP. The Kx driver is intended to replace the standard Windows driver. The standard Windows driver should be completely removed before installing the Kx drivers (which is not always easy because Windows often insists that it knows best).

The actual level looks fine, but the flat top/bottom of the waveform indicates that there is probably clipping occurring somewhere in the signal chain before it gets to Audacity.

Try turning down the “Line In” slider (second Kx interface image).

Could you post a screenshot of:
Edit > Preferences > Effects

here are two pictures:


Plug-ins folder


Abilita effetti

LADSPA : yes
Nyquist : yes
VAMP : yes
VST : no - deselect this option.

Then close Audacity and restart Audacity.

By doing so I do not get anymore the VST scanning.

I wish to know what does it do when I see this screen at startup, before this change:

What are all those dll files? Are all those not VST files?

Also, why with this setting
LADSPA : yes
Nyquist : yes
VAMP : yes
VST : yes

on my laptop I do not get this scanning windows at startup? Keep in mind I did not install LADSPA. and before updating to ver 2.0.0 having same settings I was not getting this windows.

Thank you,

On Windows, both LADSPA and VST plug-ins are .dll files.
When Audacity scans it is looking to see if there are any VST plug-ins, so it checks all of the .dll files that it finds in the plug-in search path.

If Audacity finds one or more VST plug-ins it will try to enable it and will not search again unless you tell Audacity to do so.
On your laptop you may have one or more VST effect installed.

Hi Steve,

I do not think I have VST plugins installed on my laptop.
I will post some pictures so you can see yourself and let me know. Rather, I have less items installed on the laptop as for Audacity.

Main Audacity software folder

Audacity plug-ins


Software Release

Installed applications

So, as you can see with VST enabled I still do not get this startup windows scanning.
Can you please give me an example of dll files I should find inside my plug-ins folder?

I am asking so many questions simply because without having changed anything on my comptuer, other than Audacity Software I never ever had this issue before and surely I did not have to unselect the VST settings

Thank you,

If no VST effects have been detected by Audacity then scanning will probably occur, but it should be reasonably quick. The exact amount of time taken depends on several factors including what .dll files Audacity finds in the search path.

The search path includes:

  • The Audacity Plug-ins folder.
  • The path specified by the VST_PATH environment variable.
  • The path specified by Windows Registry key HKCUSoftwareVSTVSTPluginsPath
  • The path specified by Windows Registry key HKLMSoftwareVSTVSTPluginsPath

The number of .dll files scanned, and the time taken to scan each .dll file will affect the total scan time.

If the scan occurs very quickly then Audacity suppresses the progress bar, in which case there is no visual indication that Audacity is scanning. This is probably the case on your laptop. In other words, on your laptop the scan is probably too quick to show up.


I thank you for being so detailed on the reply. Is it possible to have a screenshot of the directory that contains those VST effects?
What I do not understand is the followings: why prior to ver 2.0 I did not have this issue and did not remove the flag for VST effects and now with ver 2.0 instead the problem exists?
As for the laptop it is the opposit. On my PC Desktop I have an SSD and on the laptop I have a traditional 5400rpm HD

What makes me keep asking is that with all the variables being the same I do not find a reasonable answer to why this issue never presented itself up to ver 2.0.

Thank you,

After installing the LADSPA plug-ins you will have a lot more dll files in the plug-in search path. These are not VST plug-ins so they do not tell Audacity to stop looking for VST plugins but they are .dll files so Audacity will scan them to see if they are VSTs or not. The time taken to scan these extra dll files is obviously enough to cause Audacity to show the scanning progress bar, whereas on the laptop (with many less .dll files to scan) the scan time is short enough that Audacity does not show the scanning progress bar.

As I wrote previously, the simple way to stop the scanning is to disable VST effects in Preferences. If at any time in the future you wish to install any VST effects, simply re-enable the option.


thank you for the explanations.
I am done with this tread. I am now able to perform as needed, thanks to you guys.