Feedback Screech using Behringer UCA202

After a bad crash I had to restore the MacBook Air running Mojave I have been using to digitize reel to reel tapes, and now I get loud feedback screeches on both channels. Audio Devices setting are input on USB audio CODAC 2 (2 inputs, 0 outputs) and output on built-in output. Sound input is on USB Audio Codec and Sound output is on built-in speakers (with volume in menu bar. I’m using Audacity 3.0.5. and not getting any error messages. This had worked before restoring the Air from the crash. Any idea what I screwed up or what went wrong? - thanks

After a bad crash I had to restore the MacBook Air

I’m much more interested in how you got a Macbook Air to crash…more than once. That puts you in a really select group. Audacity and Behringer UCA-202s only work well and reliably if used on a correctly running, stable computer. That’s kind of step one.

What does the Air look like when it crashes? Do you know why it falls over? There are ways to mistreat a Mac and force it to do some pretty evil things.


I crashed the Air by trying to upgrade the machine from Mojave to Big Sur, not when I was running Audacity.
It stalled partway through the update, so I force shut it down and tried to restore it from a Time Machine backup. I was able to start the restored Air, but the hard drive was too full to run properly. I tried deleting files, but that didn’t help. When I looked closely, I found the upgrade and recovery had partitioned the hard drive into three parts, a MacintoshHD with the partially recovered Mojave disk, a MacintoshHD-DATA with the remains of the DATA disk created by the Big Sur update before it froze, and an Update disk containing the remains of the Update software. I then deleted all three partitions and restored from the Time Machine again to get my Mojave disk back.
I have not seen any problems with any other apps, but have not tested them extensively. At the moment I mainly use the Air for digitizing my collection of reel to reel tapes. (I have some vinyl that will come later.)
Does that help? Anything I should test?
Thanks, Jeff

The symptom is a little scary because you should not be able to get feedback screaming at all. There’s a significant delay between the record and the playback side even with Audacity shoveling its input sound right back out again. That’s why you can’t listen to the computer when you’re live monitoring your own performance voice either singing or speaking.

The feedback pathway is Audacity > Preferences > Recording > [_]Playthrough (de-select). See if that helps.

You can monitor what the UCA-202 is doing by plugging headphones into it and selecting Monitor On.

Keep an eye on the Audacity blue waves for recording level. Most of it should stay below 50% or -6dB.


well, that was an interesting experiment.
Following your instructions definitely stopped the feedback. Plugging in headphones showed that the music was going through the Behringer. But nothing was recording except background noise and me wondering aloud what was going on. I am attaching a couple of screen shots. I went back and changing the preferennce back on turned the feedback on. Otherwise I see no evidence that anything was going beyond the behringer through the USB cable to the computer. I switched to a second USB port and got the same response – no sign of any sound going through the USB port into the computer. The computer seems to recognize that something is in the USB port, but not to be getting a signal.

Is there some other preference setting that might be causing that or some other way that I might have screwed up, or is the problem likely to be the behringer cable?

Thanks, Jeff
Screen Shot with feedback 2021-10-28 at 8.35.02 PM.png
Screen Shot no feedback 2021-10-28 at 8.35.42 PM.png

Oddly, that’s the good news. You have selected the Air’s built-in microphone and built-in output (speakers) at the same time and turned them both up. That has the same effect as the club band turning their music system up too loud. eeeeEEEEEEEEE.

Make sure the UCA-202 is plugged in and the little green light is on.

Start or restart Audacity.

Instead of Built-in Microphone, select USB Audio CODEC. That’s the Behringer’s digital name.

Same thing with the Built-in Output.

If USB Audio CODEC doesn’t appear for Audacity to use, you may have run into the security service. I’m a little fuzzy on how this one works. Apple (upper left) > System Preferences > Security….and there it gets fuzzy. Newer systems have the ability to quarantine devices and connections for safety. See what turns up. What does that last panel say on your machine?



Thanks for spotting my misconfiguration of the input. Changing the preferences solved that problem, and I could monitor the recording by using my headphone on the Behringer.

However (isn’t there always a however?) now I am not getting any output from the Air internal speakers, although I selected them in Audacity Preferences and in Mac system preferences, and have turned them all the way up. They play music when I am playing back a recording, but don’t make any sound when I’m recording.I tried turning the headphone monitoring off in the Behringer and did not get any sound out on the internal speakers.

Any ideas?
Screen Shot 2021-10-30 at 10.22.01 AM.jpg

Turn on Audacity > Preferences > Recording > [X] Playthrough.

Thanks very much for your help and patience. Everything is up and recording. You have agreat community here.
-Jeff Hecht