"Feedback" in recording cassette tapes

I am wanting to record some music that I have on cassette tapes. I have downloaded the current version of Audacity 3.1.3. I am using a laptop with Windows 10; a JVC Stereo Cassette Deck and a Behringer U-Control UCA202. I hooked everything up the other day and did a few test runs in recording and everything worked well. I went to do some recording today and when I started recording I started getting a really loud “feedback” noise and the volume of it would increase/decrease but would not go away unless I unplugged the UCA202. It did not do this the other day when I tested everything out. When i set everything up the other day, I had the laptop sitting on top of the cassette deck and everything worked just fine. It appears to be something with the UCA202 but I don’t know what it could be since it did not do it when I set everything up the other day and I have not changed any settings in Audacity. Any assistance would be greatly appreciated.

Plug in your USB ports and turn everything on before starting Audacity. Or run Transport > Rescan Audio Devices.

Then check your Device Toolbar settings. Make sure you are recording from the Behringer, and playing back to say, your headphones.

Make sure you’ve selected the USB device as your [u]Recording Device[/u].

If you choose (loopback) or one of the options that record soundcard output you can create an internal feedback loop.