Fedup-upgraded Fedora 21 and distorted audio [SOLVED]

A month ago I upgraded Fedora 20 on my desktop to Fedora 21. Originally I had installed on it Fedora 19 from DVD-iso, so there had been two successive upgrades using “fedup”. In original F19 installation, Audacity worked just fine but when I tried Audacity 2.1.1 in Fedora 21, problems started to appear.
I could import wav-files into Audacity 2.1.1 and they seemed to work OK in playback - provided I did not try to edit them in any way.
If I tried to, for example, change the gain of one of the tracks, a black rectangle appeared where the expected “Gain: +3 dB” or similar text should have shown.
Additionally, after any attempt to edit the tracks the playback sound would be garbled fuzz. If I stopped the garbled playback by pressing the Stop button, Audacity would crash and stop responding to any mouse clicks.
I tried removing Audacity and re-installing it but to no avail. After reading Audacity FAQs I found one promising suggestion:
delete “~/.audacity-data/audacity.cfg” and start Audacity again.
This worked for me. Apparently the “audacity.cfg” file had been carried over from my Fedora 19 days and, something in it did not work well with Audacity 2.1.1.
Anyway, the problem was solved.

Dear audacityteam,

please don’t publish my comment on Fedup-upgraded Fedora 21 I wrote earlier today. Further testing proved that my problem was not solved by just deleting audacity.cfg. I’ll do more research and return to the matter…

I merged your posts to one topic. We need the details from your first post if you are still having problems.

What wxWidgets version is Audacity built with? Look at Help > About Audacity… then the “Build information” tab. The blacked out slider tooltip is an old Audacity bug but wxWidgets 3.0.2 should fix it in the next 2.1.2 release of Audacity. If your 2.1.1 is built with wx3.0.2 then there will be a lot of interface problems, because 2.1.1 should be built with wx2.8.12.

It is “quite common” for the pulse playback device to freeze up. You can choose the (hw) playback device instead and bypass pulse, as long as no other applications are using the sound device. See:

https://fedoraproject.org/wiki/How_to_debug_PulseAudio_problems .


Thanks for your reply, Gale. The Audacity 2.1.1 in use is audacity-freeworld from Fedora repository and it is built with wxWidgets 2.8.12. I tried to to change playback device from “default” to my Logitech USB headphones (hw:2,0) with the result that Audacity crashed. When I started Audacity again, my USB headphones had disappeared from device list.
Next I changed default playback device to the Ensonic ES1371 sound card installed (hw:0,0), and that seemed to do the trick. Now it seems I can edit track gain or pan with no ill effects. I’ll need to do more testing before announcing the problem solved but it looks good so far.

If the Logitech USB headphones crash Audacity a lot, you might ask on the Fedora forums about it (give them the exact Logitech model number). They may be able to make some suggestion.


Thank you again, Gale. Now that the culprit indeed seems to be my USB headphones I was considering opening a new thread asking why my USB headphones don’t work well with Audacity.
However, I’ll do what you suggested and see if Fedora forums can give me a clue. For the benefit of those reading this thread I’ll mention that my USB headphones model is Logitech H340.
The main thing is I can work with Audacity using the sound card installed. Therefore for my part I have no objection having this thread marked as solved.

OK, marked [SOLVED] and locked, but please start a new topic about the H340 if you receive some information from the Fedora forums.

That H340 model is plug and play on its supported operating platforms (Windows, Mac and Chrome). Chrome is based on Linux so one assumes there should be no problems on Linux. I did not find any real bug reports online except the H340 caused the mouse button to lock in Ubuntu 14.04, and I saw various problems about getting it to produce audio with VoIP applications and/or pulse.

If you wanted to do some tests, you could see if there is a crash in Audacity when you select H340 as default input in PulseAudio volume control and then choose the pulse recording device in Audacity.

And when you choose the H340 as (hw) device in Audacity you could see if any other applications are using the H340 for input. If so Audacity would error when you try to record, but should not crash.