"faulty sequence tags" and shifted stereo channels

Audacity 2.1.2, dmg installer, OS 10.9.5

Using Audacity to edit recordings made on a Tascam unit, 96k stereo WAV files. Everything worked great during the editing (lots of cut/paste from different source files, basically an exercise CD for a translation text book, with dialogues etc.); toward the end I checked dependencies and copied files because it says that’s “safest”. But today as I reopen the projects, I get messages about “faulty sequence tags” and also block orphans; the programs claims it can recover the files, so I let it. Looks good at first glance, but it turns out parts (but not all) of the tracks have shifted left/right channels around (no longer in sync, garbled with audio from elsewhere in the original file :open_mouth: ) so the whole edit is useless. I can only surmise that something went wrong during the file copy, but I really don’t understand how, unless there is an issue with WAV files from Tascam. Why would left/right channel go out of sync, never having been split, and only on some cuts from the source material, which hasn’t been touched either? I get the error message(s) on every one of three saved projects that I’ve worked on so far and that were fine until I closed the program down for the night. :cry:

I haven’t been able to find anything like this happening to anyone else. Any thoughts at all? Should I go back to an older version? Work from originals again? I’m on a deadline so I need to figure out a reliable work-around. Obviously I’ll now be exporting a backup WAV at the end of the day, but this is really not optimal if I’m not done with the edit.

I’m wondering if there is something wrong with my work flow. I load the source track(s) into Audacity, create a new project, cut/paste into it, then as I get done with each source I close it again (at which point I am asked if I want to save the project, which I don’t, since it’s only a window with the source track; I do of course frequently save the actual project with the edit).

Does any of that make sense? Cheers.

Project work is saved as a cloud of tiny .au files, and they alternate left-right. So I’m not shocked that an unstable system could reverse left and right by accident. But it seems your system is just garden-hosing files around at random.

The “safer” thing is just Audacity making personal, internal copies of all your external music and sound files. If you don’t do that, you will not be able to move your project.

I personally would be checking my drive health. Go > Utilities > Disk Utilities. I think 10.9 still had a Disk Check or something like that.


Thank you for the quick response and suggestion. I will do more tests on the drive, but since my laptop is otherwise functioning flawlessly, I doubt there is a hardware issue. However, you are probably correct about the AU files getting mixed up somehow. To clarify (hopefully), I’m attaching a couple of screen shots of a track, with the offsets highlighted. Both channels ought to look the same (as they do in the source file), since the mic was mono. In one case, the right channel seems to have been replaced with sound from somewhere else in the file. In the other, a small segment (orange highlight) has been replaced with something else, shifting the rest of the channel within the clip to the left (but not affecting the next clip, where everything is back to normal, for a few seconds). I had hoped that maybe only the right channel was affected, but while there are more issues than in the left, the left is also affected so that I can’t just delete one of the channels and keep the other. It is baffling. There was no crash with all of the affected projects open or anything like that.
Screen Shot 2016-11-30 at 19.32.08.jpg

my laptop is otherwise functioning flawlessly

As far as you know. The video people run into this. Video and audio production are in the short list of applications that stress a machine. You don’t need extended memory to write a letter to your mum or check your email.

If everything is truly scrambled, you can reset Audacity. Reinstalling Audacity doesn’t reset it. Audacity keeps preferences and settings separate to make updates easier. They’re sticky.

Close Audacity.

Go > Go To Folder > ~/Library. Open Application Support. Drag the audacity folder to the trash. The next time you start Audacity, it will arrive at First Birthday with no settings or preferences. And it may have lost its bad habits.

Do you have a current list of add-ons and plugins? That’s going to vanish, too. If you need to save those, that’s harder and I have to look that one up.

In Disk Utilities, the tool is “Verify Disk.” On newer Macs that has been changed to ‘Just fix it and call me if you have a problem.’ I’m not crazy about that in a diagnostic tool.

And just to cover it, do you get your cheerful ‘Chong’ when you restart the Mac? Do you ever restart your Mac?


Close Audacity.

Go > Go To Folder > ~/Library. Open Application Support > audacity. Drag audacity.cfg to the trash.

This is not a burn it off solution. If you have a bad plugin or add-on, it will still be there when you reopen Audacity.


Thank you for the further suggestions :slight_smile: . There are no plug-ins/add-ons apart from the Lame & ffmpeg libraries, so I shall ditch the settings folder in case (e.g.) there are some weird leftovers from a previous version. The drive verified fine but I also ran a permissions fix just in case, which was long overdue. I shall create a project with the default settings and see what happens. Fingers crossed.

Were these projects originally created in 2.1.2, or in some older 1.2 version of Audacity? The latter would be more understandable.

If it happens again, please post the log from Help > Show Log… so we can see the errors.

If you want a mono file as a result of your work, it might be best to paste into a mono track (select the track and do Tracks > Stereo Track to Mono). There is a bug in 2.1.2 with pasting mono into stereo which will be fixed for the next 2.1.3 release when that arrives. However the problem should be visible immediately.

If you want to try 2.1.3-alpha (it’s fairly stable now) you can get it from the topmost folder on http://www.audacity.homerow.net/index.php?dir=mac/.


Hi Gale, thank you. The projects were created in 2.1.2. The .wav files have two channels by default, so even though the left & right are the same they ought to be recognised as stereo. I haven’t tried 2.1.3 yet; however, today I did delete my preferences (etc.) folder, rebooted, and started afresh with one of the projects. After editing together the tracks and saving the project, I quit audacity and then reopened by loading the project file. Got the message, “project check… detected 32 missing alias (.auf) blockfiles.” I let audacity “regenerate alias summary files,” saved, quit, opened again; now the project seems to be fine. So far no dislocations.

Am I getting this messages because of the wacky way I’m editing? I don’t know how else to do it since there’s no hold-all folder within the program for all the source files, such as in Final Cut, say. So I load each source into audacity, which of course creates a project window for it; then I copy whatever I need, paste it into my actual project, and when I’m done with the source file I close that window without saving (I don’t need a project file for my raw material…). Is there a better (or correct) way of doing this that I’m missing? Possibly these are two different issues.

I will try to take the time also to do some work on this using another computer tomorrow, just to make sure it’s not the hardware or OS on this machine.


hold-all folder within the program for all the source files,

Right. That also means we can’t tell you Clip Info. When work comes into Audacity, it loses all its original personality (except sound quality). Even worse, Audacity works at 32-bit floating internally to make effects and filters seamless, so the sound is even further away from its original format.


Hi Koz, I’m not complaining at all about audacity’s inner workings, just trying to establish whether my workflow is at fault or there is a better way of editing multiple clips together. It’s been a while since I’ve used audacity, but I’ve never had any issues with file integrity, so I’m a bit freaked out since I have to assemble 17 chapters of dialogues and exercises by Dec. 10. Of course it would be useful to be able to trace a clip back to its source file (in that case I might have been able to repair the original damage) but I’ll trade that for the flexibility I’m getting in audio manipulation, as long as I can rely on the internal workings not to let me down. That’s not too much to ask now is it (i.e. spare the sarcasm please :wink: ). I’ve read through the release notes and it sounds a bit like the “Bug:137” listed under “Moonphase.” If I can replicate the error (I hope not…) I will upload the log, but it really doesn’t say much except that it can’t find the files on the first reopen after saving the project and exiting. Furthermore there is a note that “Left-clicking in a stereo track to merge a clip at a split line may cause other clips to move” and I’m wondering whether that inadvertently happened before when the content shifted (even though I did not do any mono->stereo conversion).

I made a quick test edit on my other system, an older iMac, OS 10.11.6, same audacity build (2.1.2 release), and I’m not having any issues except for extreme sluggishness after about the 5th edit (which is why I would prefer not to edit on this system). It’s not quite identical since the ffmpeg library is not installed and I’m loading the source off a network drive rather than the local HD (and yet, no lost files…). Hm. Here’s another random thought (grasping at straws): on the macbook pro the projects are in a subdirectory under the .wav files. idk. :confused: Should I upgrade (the macbook) to Sierra or would that invite more issues than it might solve?

Should I upgrade (the macbook) to Sierra or would that invite more issues than it might solve?

That upgrade may take you out of forum help. I don’t have a Sierra machine and I don’t know any of the other elves do, either.


I think it’s still true the default Audacity tries to save projects in /Applications. That’s not a good idea and can lead to instability if it works at all. I do everything on the desktop and move work off to /Documents or other user folder when I’m done or have to stop work for a while.


Peter and I have Sierra, at least.

Audacity does support Sierra (see http://www.audacityteam.org/download/mac/#sysreq) - though at the moment there are problems on some machines that plugins and/or LAME and FFmpeg are blocked by Gatekeeper.


If you did hit that merge bug, it is fixed in 2.1.3-alpha now, so it will be fixed in 2.1.3 when released.

On my testing of that scenario, the AUF files are not deleted from the project you pasted into, which would have to happen to produce the missing alias block files error. Where exactly are the source files (what path)?

However you are probably making it more confusing and inconvenient than it needs to be by using File > Open… for the source files, which causes each file to import into a new project. If instead you use File > Import > Audio… then the file will import into the same project instead of a new one.

Also, the AUF (alias) files are created because you have chosen to read uncompressed files (such as WAV or AIFF) directly from the file, rather than copy their data into the project. If you read directly, the source file must remain exactly where it was when you imported it into Audacity - you can’t move, delete or rename the source files without corrupting your project. So consider going to Import / Export Preferences and changing the first preference at the top to “Make a copy of uncompressed audio files before editing (safer)”.


Thanks for all the suggestions. I have not had any more problems today since starting over, so I hope it was a gremlin that has decided to depart. One of these things probably fixed it (if it is fixed) and I’m sorry I didn’t have the time to isolate which: I verified the drive (it was fine), fixed permissions (long overdue), deleted the audacity settings folder in the library, and updated to Sierra (Lame & ffmpeg working fine, phew). I look forward to 2.1.3. If I have any more insights into what happened (or the problem recurs), I will share. Cheers. :sunglasses:

Well, today during my attempt to save a new project Audacity (v2.1.2) popped up with a debug message before crashing (“SamplingTools needs to take control of another process for debugging to continue”). On restarting the program it managed to recover most of the project except for two clips, where a couple of seconds of the right channel had gone missing (I managed to replace those clips) but nothing got moved around otherwise. As you’d explained to me, that probably means a couple of .au files didn’t make it. Not really sure it has anything to do with the previous issues I was having, unless these Tascam .wav files are causing issues once in a while. So maybe this doesn’t even belong in this thread, but since Audacity generated a debug report my question is only, does this get sent to the developers automatically or should I find it and submit it? Cheers, G.

The (Audacity) debug reports do not get sent to us automatically. I see you have attached them at https://forum.audacityteam.org/t/debug-and-crash-on-save-project-as/44217/1 Thanks. I will ask there about that Sampling Tools message. It does not come from Audacity.