failed installation on linux

Hi all,

I am a beginner at linux but I can’t use package managers like YUM or RPM becuase my admins don’t want me to. My next problem in installing audacity 1.3.8 on fedora 6 by myself

./configure went ok
make reports the following:


make[2]: Entering directory /import/thetis6/alefevre/audacity-src-1.3.8/lib-src/taglib' /bin/sh ./config.status --recheck running CONFIG_SHELL=/bin/sh /bin/sh ./configure --disable-option-checking --prefix=/users/thetis/alefevre/install/bin --with-wx-config=/users/thetis/alefevre/install/bin/wx-config --disable-sqlite --disable-external-libs --disable-alsa --disable-programs --with-pa-include=../portaudio-v19/include --cache-file=/dev/null --srcdir=. --no-create --no-recursion checking build system type... x86_64-unknown-linux-gnu checking host system type... x86_64-unknown-linux-gnu checking target system type... x86_64-unknown-linux-gnu ./configure: line 1437: syntax error near unexpected token taglib,1.4’
./configure: line 1437: AM_INIT_AUTOMAKE(taglib,1.4)' make[2]: *** [config.status] Error 2 make[2]: Leaving directory /import/thetis6/alefevre/audacity-src-1.3.8/lib-src/taglib’
make[1]: *** [taglib-recursive] Error 2
make[1]: Leaving directory `/import/thetis6/alefevre/audacity-src-1.3.8/lib-src’
make: *** [audacity] Error 2

I installed automake to fix some warnings I had before but this message still shows up … if anybody has a clue what’s going on I’d be thankful for it

Best
titusdt

Download the full source tarball (.tar.bz2 file, 17.4 MB) from here http://audacityteam.org/download/beta_source#recdown

If you get the same error, try running ./configure --with-lib-preference=“local system”
I don’t know if this will work, but it looks like your “taglib” is too old, and if you do not have admin rights to update it then this may be a way round the issue.