extreme feedback

so I’ve got macbook pro running osx 10.9 and hooked up 2 atr2100 mice. i went into midi setup and created aggregate device but when i go to audacity and try to record all i get is loud squealing feedback. pretty sure its not the mics since they both work fine on their own but when i turn both of them on its over. new to all this and jet trying to setup on the cheap for a podcast. any help much appreciated. thanks

Is that why it’s squeaking :smiley:

Seriously though, check that “Software Playthrough” is off (Transport menu) and ensure that you have headphones (not speakers) set for playback.
Those are probably the two most likely causes, so best to check them first.

Is that why it’s squeaking :smiley:

hahaha i just noticed “mice”. i love autocorrect but only half the time :laughing:

You’re making it awfully hard on yourself, trying to combine 2 USB mics.

Something like a Behringer UMC202HD and 2 Behringer B5’s is about the same price. And you have the choice between cardio or omni capsules for the mics. You can also attach a small mixer, if ever needed. Omni capsules are worth having, if you ever need to record more than 2 people.

Now you have one mic that works well, but it is a mic made for singing, not for spoken word, or interviews. And aggregating it with a second, identical mic may work, it usually works, or it may not. In seldom cases, drift between the two AD’s is so bad that core audio can’t fix it. And then it’s end of story.

In seldom cases, drift between the two AD’s is so bad that core audio can’t fix it.

Didn’t it ask you which microphone you wanted to use as the Master? What’s why. The microphone you picked will come out in perfect time at the end of the show and the other will be wherever it drifted to. Last time I did this, you can’t split an aggregate mic up into individual voices to fix it. Consult your instructions. That part may have changed.

The graduation from one microphone to two is the killer. That’s not convenient any more. Computers don’t handle multiple microphones well.


I don’t have two USB mics (I don’t have any USB mics), so I tried aggregating a Behringer UCA 202 (stereo line-level USB interface) with the on-board sound card. I was pleasantly surprised how well it worked. I was able to record 4 independent tracks. The OS X aggregation service “seems” to be clever enough to pull the slave device back into sync if it starts slipping (I’ve not tested thoroughly enough to say that this ‘definitely’ works, but from limited testing it seems to).

In my first reply, I suggested a couple of things to check first. If the problem persists after that, then we can start paring down to locate where the problem lies.

It works well with “nice” devices. Like USB audio class compliant devices.

Notorious exceptions:

  • some Tascam interfaces (Tascam doesn’t support aggregating at all, but some of their interfaces work)
  • a few older M-audio interfaces (crappy USB chips)
  • some identical devices (maybe cause Core audio can 't tell them apart?)
  • most USB mics (too much clock drift)
  • most cheap USB to jack/XLR cables (too much clock drift)
  • too much (>16) channels on one or both devices (Core audio can’t keep up?)

It even works well when aggregating PCI, Firewire and/or USB devices. I’ve never tried aggregating 3 or more interfaces, but have been told that works too.