I’ve just downloaded the beta version (1.3.5) of audacity and have been trouble simply exporting my mp3 files after they are edited for some reason.

I have some concerts that I’ve downloaded that all have about a second or so of silence at the end of each track, so what I’ve done in the past is to just go cut or delete that silence out (so that the concert flows naturally once burned to a CD), and export the song as mp3 replacing the previous song, but since using the newer beta version each time I do this, if I reopen the song, it has the still has the silence at the end of the track.

I thought that maybe I was doing something wrong, so I went back to the older audacity and I’ve had no problems… is there a setting, or something else that I should be doing to remove the silence at the end of these tracks?


CD burning programs naturally want to add two seconds of silence between songs. Sometimes you can turn that off in the authoring/burning program.

Could that be it?


No that wasn’t it, I make sure that I have that turned off before I burn, but importing the song into audacity shows the space of silence there, it was that way from the source that I got the music from, I just wanted to delete it, I had no problem doing that before downlaoding the beta version of audacity.

I uninstalled and reinstalled the software, and it’s working fine now, I’m not sure why it wasn’t working before?

So fixed!

Does it work if you put Labels at the in and out music points, select them, and File > Export Selection?

If I get a minute, I’m going to try and recreate your problem. Did you start out with an MP3 file?


Oh, wait. Now 1.3.5 is working?

This must be a Windows machine, right?


Problem did not go away? I thought it had, and I’m a bit perplexed.

It is a Windows machine, Windows XP Pro.

Yes I start with a MP3 file, it’s a full concert, but the downloaded concert has about a second or so of silence at the start and end of each track, so once it’s burned to a CD, even if you ask the burning software to not leave silence between the tracks, there is. So I have in the past always used audacity to go in and just select the silence, and delete it, then file > export> mp3 and that’s it. Only when I do that with the beta version, after I’ve exported the file then closed it, and then reopen the file to check and make sure that the silence is gone, it’s there again, it’s like once the file was exported, that it didn’t save the changes I made, or it added silence back to the track.

So after I thought I fixed the problem by uninstalling and reinstalling , I in fact didn’t.

Now if I go back to the other version of audacity, the latest version, not beta, I follow the same procedure and I have no problems.


I’m just experimenting, and when I take a track and cut it in halve, then export it (mp3) and the open it again, I’m still getting a silence in the beginning of the track, almost like a fade into the track, could it be doing this as it imports? It’s not long, but long enough that I noticed on the CD I burned.

I’ve found that exporting the file as a WAV file seems to enable me to trim the songs (and they stay trimmed), but if I export them as MP3, I always end up with a bit of silence at the beginning and ending of the track, which normally wouldn’t be a problem, but if you have concert like I do that you want to flow without a hitch…

Any suggestions? How can I export them as MP3 and not pick up this bit of silence?

Is this just a very short silence? (about 25 milliseconds?) If so, then you can’t do anything about it - it is a limitation of the mp3 format. This is why Adobe Audition uses “.cel” files - it is a proprietary modification of the mp3 format that avoids this limitation.

WAV, FLAC, and Ogg do not have this problem.

Yes that’s about what it is, but definitively noticeable once burned to a CD.

Well that answers the question though, I’ve just been exporting them as Wav files, it exports faster anyway, then burning them to a CD, which is the end result i want anyway.

Thanks for the answer!