Exporting wav files to thumb drive.

Audacity 2.0.5
Mac OS 10.6.8
dmg installer (I think)

I I have a newer car radio that can recognize information via usb. This is great because I can drag files to a new thumb drive every time I get in my car, and it’s a lot better than burning a CD that can’t be revised. However when I export a file as a Microsoft wav file (the only thing my radio will recognize) two files go to the thumb drive. If I copy 40 songs then 80 files are stored. When I go to play the music I have to skip past the first 40 entries because they contain no content. It’l getting to be irritating. Has anyone else had this problem?

I doubt it will help, but try exporting WAV to your Desktop then drag the files to the thumb drive.

Look in the Manual for the thumb drive in case it is configured to make automatic backups.

Let us know what the solution was. Give us the make and model number of the thumb drive if it was a problem with the drive.


That’s not even a Mac thing as far as I know.

Plug the thumb drive back into your Mac.
Finder > Preferences > Advanced > Show all filename extensions (you can turn this off later – I leave it running).

Double click the drive to open it. Can you find both files? Post a screen shot here on the forum. If the drive opens in folders, post that, too.

Shift-Command-4 will let you drag a fence around just that window and not snap the whole screen.

Here’s how to post a file:



With Show all fileneme extensions only the original music files show. The problem only shows up when I go to play the music on the radio. It’ll step from song to song reporting “no information” until I get to the actual music files then they play just fine. I honestly don’t know what good it will do to show a picture of the files. There just isn’t anything there. I have 4 PNY 8 gb thumb drives and I’ve reformatted two which changed nothing. I usually save the files I run through Audacity on the desktop then drag them to the thumb drive for that day’s auto adventures.

I just tried a little experiment. I ran 3 more music selections through Audacity and directly saved them to an SD card. Then using a Converter plugged that directly into my radio. The same problem came up. Three times it said “NA File” then the next three played just fine. It isn’t the thumb drives, because the problem shows up with an SD card too. When I open up the SD card only the three pieces of music are listed. Dang…

Here is a screenshot of the SD card with two files on it. When I go to play them the first two files (items 1 and 2) both show NA File, then the next two play.
Screen shot 2014-02-23 at 4.46.44 PM.png

Are you sure this direct saving to thumb drive or SD card isn’t the issue?

Have you tried exporting to the Desktop then drag the files to the thumb drive or SD card from there?

Are you sure Time Machine isn’t doing something odd?

Have you looked in the Manual for the radio? Has it always done this?


You’re going to find that the radio is expecting a management, INFO or MetaData file to go with the music. Instead of blind playing the music in “Stupid-Mode,” it hangs. There might be a way to turn that off.

If it’s a Sony radio, then it will be in a proprietary format and you can’t turn it off.

Radio Instructions time.