Exporting true stereo file

I have used Audacity for many years - older version until today.
Nothing short of fantastic program.
For the 1st time, I need a stereo - (2 channel file).
Purpose - to use 2 totally different recordings.
(playback 2 separate sounds - L & R speakers.
It plays back in Audacity as stereo - just as it should.
Play either or both tracks - L to R perfect.
Save as MP3 - any combination.
One track is getting lost.
Moving to current version made no difference.
I must be missing something.
I’ve recorded a lot of tracks.
Never saved except as mono or have needed stereo tracks separated.
Which has worked perfect.
Have latest LAME installed.
Thanks,
Ken

IMHO, mp3 is unusable for this kind of application.

When you convert to mp3, it will downmix less important frequencies almost to mono. And I think that’s what’s happening in your extreme use case. The MP3 encoder is designed for music, and music only. It will cope with voice, but it’s not ideal. And it simply won’t cope with a lot of test signals, as I found out myself.

If you keep the audio as a wav, channel separation is 100%. When you play it back, some signal will leak from left to right and vice versa. If your playback equipment is good, this will be 10 to 20%, roughly. That doesn’t hurt music at all. If the equipment is not so good, it might be 50% or even more. It still doesn’t hurt the music, unless it adds distortion. And that happens a lot with lesser equipment.

To understand your problem better and maybe come up with a different solution, I would like to know more about your application. Could you unveil what the exact goal is? :smiley:

That comment interests me. What does it mean?

What does it mean?

This is where we need an accurate description of the show.

On the left is Disco Madness and on the right is Shostakovitch and Shostakovitch is vanishing?

Koz

Could try making the two separate tracks into a stereo-pair using “Make Stereo Track”.

The export dialog for mp3 has the option (radio button) “Stereo”.
Unlike “Joint Stereo”, this keeps the channels separated, no m-s/l-r switching.

There is also “dual channel mode” (using -m d). To quote the manual:

(d)ual mono
In this mode, the 2 channels will be totally independently encoded. Each channel will have exactly half of the bitrate. This mode is designed for applications like dual languages encoding (for example: English in one channel and French in the other). Using this encoding mode for regular stereo files will result in a lower quality encoding.

However, I doubt that is the problem because even the Joint Stereo option gives very good channel separation in “normal” use.

Since I did that over ten years ago, I decided do try it again. MP3 encoders have evolved, yes?

This what I did:

  • Make a mono track, white noise, 30 sec
  • Add a second, empty mono track
  • Pan one left, one right
  • Export to stereo wav, 16 bit, 48 kHz
  • Import the result to view and play

Lo and behold, the channel separation is already ruined BEFORE entering the mp3 encoder. Why?

I was wrong, as in this case it isn’t the mp3 encoder, it’s Audacity. The best channel separation you can get, is around -72 dB.

After exporting to mp3, joint stereo, cbr, 128 kbps, the stereo separation has gotten better: -84 dB. :open_mouth:

I remember this from making audio test signals to store on an ipod. In the end, I created wavs, because with mp3’s unexpected things happen. And I did it in Deck, way back then, but it also involved a lot of experimenting.

I expect you can avoid this by not using pan laws. But I have no clue how to create L and R channels without pan. And this is just a test, with other sources, other things will happen.

And stereo to mono and the reverse are a bit funny in Audacity. FI, if I want to paste a mono sound into a stereo channel, it gets pasted to a new track.

Another procedure:

  • Make mono track, insert audio
  • pan left
  • export as wav, add channel in the export dialog
  • import the result to view

Same result:

(not noise, some random recording)

As things stand now, I can’t figure out how to make a stereo wav with a signal on one channel and nothing on the other channel.

I can’t even tell what that is on the other channel. It has no spectrogram and isn’t audible at normal level. Dithering noise? An artefact of the Audacity graphic engine?

It’s not a 16 bit noise floor either, as it is constantly -72 dB and not -96 db. But it’s certainly enough to render some measurements impossible. If you don’t notice, it might set you off on a wild goose chase…

That looks to me like “dither noise” in the right channel.

And there’s no spectrogram because it’s over 8.000 Hz. Over a 100 kHz. But I can’t set spectrogram prefs any higher. Of course, it doesn’t matter for audio, but it does for measurements.

Any way to turn off dithering?

Preferences > Quality → High Quality settings

I actually meant this mode but I assumed it would have been renamed within Audacity because “Dual Mono” is normally used in the sense “two channels, same content”.
Thank you Steve for looking it up.

There’s also a “-m s” option which is closely related to “-m d”, but slightly different.
The “-m s” switch renders stereo as L/R channels, but in contrast to the “-m d” switch, the bit rate may vary from one channel to the other so that the audio that has greatest need for bits gets them. In the “-m d” mode, the bits are shared equally between the channels.

In Audacity, the “stereo” option is equivalent to the “-m s” switch.

For normal stereo, the “-m j” switch should be used (this is the “Joint Stereo” option in Audacity). The JS option provides better correlation between the channels for sounds that are centre panned, so better “stereo sound staging” than the “Stereo” mode (applies to encoding with LAME 3.9.0 or later).

No problem Robert, I was looking this up just a few days ago so it’s all fresh in my mind :slight_smile:

Have you got steps to reproduce that? The mono sound should be duplicated into both channels of a stereo track.

Gale

Thanks, Steve. That solves the question with the noise.

I could find a procedure to loose one channel:

  • Create new project, add mono track.
  • import audio (I used a bird recording)
  • add another mono track
  • paste another mono audio, copied from another project (I used a guitar recording)

The first track ends up empty, with a wallpaper like background, that turned grey after I made a screenshot:

Of course, after export there is one channel missing, as it is already missing when playing back.

Note that the file name for the first audio is still present, the second audio doesn’t inherit a file name, as it is pasted.

Bug? Reproducable?

That’s because “Sync-Lock” is enabled: Audacity Manual

Those steps give you three tracks, but assuming you are using 2.1.3-alpha, yes that is a serious bug. The paste with Sync-Lock Tracks enabled should move the imported audio rightwards, not replace the audio with nothing.

Regression on 2.1.2. I will add it to Bugzilla when tested further.


Gale

That was with Audacity 2.1.2 on Mavericks…

Haven’t touched the alpha build yet. And I ended up with two tracks, as intended, to go to a stereo track.

Here’s a typical scenario of being blind to the obvious.
I created the 2 single recordings, made a stereo track - saved as mp3.
Audacity played and separated great.
I afterwards tried playing it in my default audio player VLC.
I don’t know why, but it loses a track - could just be my settings as well.
Even old winamp separates great.
I really do appreciate the feedback and ideas to deal with this.
FYI my project - Our summer business has a short narrow gauge train.
Last fall we started building a small part of an Old West Town the train passes.
I will run a small stereo amp that would provide a separate sound in 2 locations.
(SD card or USB stick)
Blacksmith shop + Saloon music( by using L-R speakers)
(I wish 5.1 or 7.1 worked as easy)
I have to operate it off 12v due to location, so conserving power use.
PIR sensored, likely some motion after I get this operating.
Hence, 1 amp - stereo.
May explain my blindness to simplicity.
Thanks,
Ken

Sorry, Steve, forgot about this before.

That background turned to solid grey seconds later. After making a screenshot. Fortunately, you recognized it.

It is possible I enabled it by accident. It is even very likely I did, but I don’t know how. And it still shouldn’t lose the audio in the track, I suppose?

It probably happened because I was looking for different ways to select tracks. I think shift shouldn’t be used as a modifier, enabling functions, but only as a way to make multiple, non-continuous selections. But maybe that’s my personal distortion, as a Mac user?

Anyhow, now you know why I never store projects, only exports. I’ve been bitten by this kind of user errors once too many.

I’ve repeated the test, and now, the first track doesn’t disappear. Is this supposed to happen with sync-lock on?