Exporting file not appearing in windows explorer

Really strange problem on Windows 10, HP G61 Laptop.

I export the file to MP3, WAV whatever, it goes through the motions of creating the file (asking me where to save it, what to call it), starts exporting (box with the two green progress bars comes up), it gets about two thirds of the way through (about 5 seconds left) and then the box disappears. I think great it’s created the file but then I go to wherever I asked it to save it and it’s not there.

I went to the diagnostics log and all seems normal, it found the FFMPEG files and dlls etc (see below)

The only thing out of the ordinary is the line File not in path. Anyone know what’s wrong. I’ve tried everything apart from reinstalling Audacity. Restarting computer, deleting appdata, trying uninstalling and reinstalling Lame…what is going wrong???

Here’s the diagnostic log:

22:53:51: Audacity 2.4.1
22:53:51: Trying to load FFmpeg libraries…
22:53:51: Trying to load FFmpeg libraries from default path, ‘C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll’.
22:53:51: Looking up PATH environment variable…
22:53:51: PATH = ‘C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\WINDOWS\System32\OpenSSH;C:\Users\HP\AppData\Local\Microsoft\WindowsApps;’
22:53:51: Checking that ‘C:\Program Files (x86)\FFmpeg for Audacity’ is in PATH…
22:53:51: Warning: FFmpeg directory ‘C:\Program Files (x86)\FFmpeg for Audacity’ is not in PATH.
22:53:51: Temporarily prepending ‘;C:\Program Files (x86)\FFmpeg for Audacity’ to PATH…
22:53:51: Checking for monolithic avformat from ‘C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll’.
22:53:51: Error: Couldn’t find symbol ‘avutil_version’ in a dynamic library (error 127: The specified procedure could not be found.)
22:53:51: Error: Couldn’t find symbol ‘avcodec_version’ in a dynamic library (error 127: The specified procedure could not be found.)
22:53:51: avformat not monolithic
22:53:51: Loading avutil from ‘avutil-52.dll’.
22:53:51: Loading avcodec from ‘avcodec-55.dll’.
22:53:51: Loading avformat from ‘C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll’.
22:53:51: Returning PATH to previous setting…
22:53:51: Actual avutil path C:\Program Files (x86)\FFmpeg for Audacity\avutil-52.dll
22:53:51: Actual avcodec path C:\Program Files (x86)\FFmpeg for Audacity\avcodec-55.dll
22:53:51: Actual avformat path C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll
22:53:51: Importing symbols…
22:53:51: All symbols loaded successfully. Initializing the library.
22:53:51: Retrieving FFmpeg library version numbers:
22:53:51: AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
22:53:51: AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
22:53:51: AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
22:53:51: FFmpeg libraries loaded successfully.
22:54:51: Using internal LAME
22:54:55: Using internal LAME

Yes, that all looks normal.

Does the problem only occur with one specific project?

What did you call the show? Did you put a date in the name? Use ISO dates. Today is 2020-07-03, not 7/3/20. Slashmarks can confuse the machine.

Use Upper case, lower case, numbers, -dash- and underscore only. No other characters. Also stay away from the Microsoft magic words such as COM, LPT, etc.

Did you use Windows search to try and find the files? Try exporting as a very simple name like Myfile just for a test.

Re-installing Audacity doesn’t clear Audacity. There are system files you can delete which does that.

Are you trying to save to a Network Connected Drive? Google Drive, iDrive. Try saving to a local drive instead.


This came up a while ago.

Do not use the following reserved device names for the name of a file:

I checked CON, PRN, AUX, NUL, COM1 and LPT1–all OK, assuming others also good.
I see that COM1 & LPT1 etc. are excluded but wonder if COM & LPT should also be excluded for safty’s?


Yes it does, I just tried recording a new track and that exported to Mp3 fine. I’ve also tried transfering the file (via USB) to another PC and it won’t export to MP3 there either. Goes through all the motions with the progress bars half way through and then disappears.

Thanks for all these suggestions. I’ve tried just calling it ‘Untitled’ and exporting and same thing, it goes through the motions but end result is no mp3 file when I go to look for file on desktop or in c drive or wherever. I’ve tried multiple locations.
As per Steve’s response I wonder if the aup file is corrupted because it keeps crashing Audacity after the failed Mp3 export. Is there any way to repair these?

How big is the project? (Number of tracks, length of tracks)

It’s my band’s rendition of ‘Something’ so, 2’.30" Five tracks, drums, bass, keys, vocals, guitar. Is there anyway to repair the file do you think? Took me hours.

  1. Make a backup copy of the project (“Save Project As…” and name it “Something-backup.aup”)

  2. In Preferences, check that “Ignore blank space at the beginning” is NOT selected:

  3. Select the first track and “Export Selected Audio” as “WAV” “Encoding 32-bit float”.

  4. Repeat step 3 for each track.
    I’m expecting that one track will fail.

  5. The exported tracks can then be imported into a new project.

How much of the project were you able to recover with these steps? (we can then try to recover the rest)

Open the AUP file in a text editor and look at it. Don’t change or save anything.

It should look roughly like this.

That’s been gussied up a little for the picture, but that’s the idea. It’s roughly Englishy words. It’s a programming style. The red box indicates the name you gave the project when you made it the first time.

If the AUP is blank, then the problem is obvious. If it has graphic characters, all black blocks, or nonsense trash, then that’s the end of the show. Sometimes you can rescue a first-pass recording when you lose the AUP file, but not an edit. Edits scramble things and the show depends on details in the AUP file to straighten everything out.


Many thanks Steve but unfortunately all of the tracks are failing to export as Wav 32 bit floats. I assume that you mean exporting them by highlighting each track individually and then File/Export/Export as WAV etc?

Ah, hold that thought. I just noticed the ‘export selected audio’ option and that seems to work. :smiley:

Thanks Koz but I followed Steve’s suggestion and he was right, one of the tracks was corrupted, the keyboards. Funny the way Audacity doesn’t tell you one of your tracks is buggered instead of making you think it’s exporting happily but I suppose it has to give you a run for your money sometimes! :wink:

I’m guessing that you’d like to recover that track if possible.

Unfortunately I’m not able to give you a quick way to fix it, because I don’t know what is wrong with it - this kind of problem rarely happens.
What I can do is give you instructions for sharing that track with us so that we can try to determine what the problem is, and hopefully fix it.

  1. Open the backup copy of the project.
  2. Ensure that it plays correctly.
  3. Delete all of the tracks except for the bad track (click the in the top left corner of a track to delete it)
  4. Save the project with a new name (“Save Project As…”), and call it something like “bad-track.aup”
  5. Quit Audacity
  6. Make a ZIP archive containing the file “bad-track.aup” and the folder “bad-track_data” (Zip and unzip files - Microsoft Support)
  7. Upload the ZIP file somewhere (such as dropbox, Google Drive, One Drive, Sendspace.com, …)
  8. Post the link to the file in your reply.

(If using a “web drive”, ensure that you the file to “public”)

I also, all of a sudden, I can’t save two open files. I’m using version 2.3.1. I know it’s not the most recent version, but I can’t download the newest one while I have the files open and can’t save them to re-open once I download the latest version. Do I have any option besides losing the two files I have open? I tried to save them as a project, but that won’t save either. HELP!

Since I can’t get open files to save (do not appear in Finder, I tried to save it track by track by “export selected audio”, but this doesn’t save either…
Now what?

Many thanks Steve but I’ll trouble you no further. I managed to recover keys track from an original recording!