Exported M4A file contain zero data

Moderator note: Moved to the correct Windows board
I am using audacity 2.05 on Window 7. It had been an effective solution to me until lately. I had problem with result of exporting to M4A ACC format. It was working okay yesterday. However after window auto update of system 7 Audacity exported an empty M4A ACC file. Meaning it successfully exported the file but on checking the size it showed zero byte. Not useable by the intended app. I tried on the mac too. Same result. I had reinstalled both audacity and the FFmeg libray yielded sam result. Is it a bug how do I fix it? Now it grounded my project to a halt. If this cant be a fixed I have to look for alternative and I am sad about because it such an excellent product.

I assume you mean Audacity 2.0.5 and AAC. If you don’t have Audacity 2.0.5 supplied by us, you can get it here: http://audacityteam.org/download/windows .

Windows Update cannot affect Mac OS X even if you dual boot Mac and Windows.

Reinstalling Audacity on Windows will not change Audacity settings unless you enable “Reset Preferences” half way through the installer.

Where does it say that the exported file is zero bytes - in Windows Explorer or your mobile app?

Note that you can export as WAV from Audacity and convert to AAC in iTunes.

  1. Open iTunes and click Edit > Preferences (or iTunes > Preferences on Mac)
  2. Click on the leftmost “General” tab
  3. Click the Import Settings button half way down on the right
  4. In the “Import Using” dropdown, choose “AAC Encoder”
  5. Click OK and OK
  6. Select the file to be converted, then right-click or control-click over it and choose “Create AAC version”

If the WAV has no data you will need to look at your Audacity track layout and find out why.


This is what I found in the log:
1:01:09 AM: Error: FFmpeg : ERROR - Can’t open audio codec 0x15002.

How do I fix this


Thanks for checking the Log. Please tell us exactly what you are doing and where to produce that error. Are you exporting M4A (AAC) from Audacity, if so, is this on Mac or Windows, or both?

If you are exporting M4A (AAC), what is the Quality setting? Open File > Export… , choose “M4A (AAC) Files (FFmpeg)” then click the Options… button to check. And what is the Project Rate bottom left of Audacity? I ask because that “Can’t open audio codec 0x15002” is a potential issue on Linux if you export M4A (AAC) and the project rate is below 22050 Hz. It should not occur on Windows if you download FFmpeg from Audacity Manual .

Let us know. Is it only today that you exported AAC at a different project rate?


I resolve the problem by sliding the quality to 10500 as per your suggestions and export M4A ACC successfully. Thanks for your help.

There is no such setting. The Quality slider goes from 10 to 500.

I also tried on Mac OS X using FFmpeg 0.6.2 with a project rate of 8000 Hz and Quality 10 or Quality 500 but files are exported.

Can you tell us exactly what project rate and exactly what quality setting causes the zero bytes problem? The quality setting applied is the middle value you see (between the 10 and 500).


Also having FFmpeg : ERROR - Can’t open audio codec 0x15002 resulting in 0 byte .m4a file.

I am using Windows 8 and Audacity 2.1.1.
Copied a .mp4 file into Audacity and silenced some parts of the resulting audio file. There were six (6) parts each part had : Mono, 48000Hz, 32-bit float. Project 48000Hz.

Went: File > Export audio… > File name: zzz.m4a. Save as type: M4A (AAC) Files (FFmpeg) > Save > Output channels: 6 > OK > Edit metadata > OK > : FFmpeg : ERROR - Can’t open audio codec 0x15002. The resulting file zzz.m4a has zero bytes.

Also went to Options > Specify AAC Options: and tried Quality levels from 10 to 500 and still get the message: FFmpeg : ERROR - Can’t open audio codec 0x15002.

Please assist.


The “M4A (AAC) Files (FFmpeg)” item only exports maximum two channels because the “libvo-aac” encoder it uses is limited to two channels.

So in your case, you must choose “(external program)” instead of “M4A (AAC) Files (FFmpeg)” and type out a command that tells Audacity to use the native FFmpeg encoder instead.

You can use a command like either of these two:

ffmpeg -i - -strict experimental -c:a aac -b:a 240k "%f"

ffmpeg -i -  -strict experimental -c:a aac -q:a 10 "%f"

Change the “240” in the first command if you want a different bit rate, or if you use the second command, change the “10” if you want a lower quality (10 is the maximum quality).

The file name chosen for export should be typed in the export dialogue as normal, not in the command. When you type the file name, add


to the end of the file name.


Thank you.

I entered:

ffmpeg -i -  -strict experimental -c:a aac -q:a 10 travqq.m4a

but no drive activity.

Searched for travqq.m4a but could not find it. Where would the travqq.m4a file be found?


My sincerest apologies!

Made a boob… but got the understanding now and all is well.

Thank you very much for your guidance and instruction.


That is OK, I made it clearer in my post that the file name chosen for export should be typed in the export dialogue as normal, not in the command.


Hi, I’m here 'cause I also have an issue with audacity converting a 6ch DTS audio to a 6ch aac.

I prefer to explained visually, so I capture an image of what I’m doing and the problem itself.
Please take a carefully look to the link (click once on image and then select ‘View raw image’ to expand).


Image detail:
1. This is the audio I have. A 6 channel dts. I want to convert it to a 6 channel 192kb aac.
2 & 3. The options I assign in audacity.
4. Final message.

I tried to download and reinstall ffmpef… No result.
Tried to change to 320kb instead of 192… no result.

Any ideas what is going wrong?

As explained a few posts above ( Exported M4A file contain zero data - #8 by Gale_Andrews ) the “M4A (AAC) Files (FFmpeg)” item only exports maximum two channels because the “libvo-aac” encoder it uses is limited to two channels. Follow the steps in Exported M4A file contain zero data - #8 by Gale_Andrews to choose “(external program)” instead of “M4A (AAC) Files (FFmpeg)” and type out a command that tells Audacity to use the native FFmpeg encoder instead.

Due to another problem, the quality control after opening the “M4A (AAC) Files (FFmpeg)” item does not change the quality, but you can specify the quality when you use the native FFmpeg encoder at the command-line.


Seems to me that ‘libvo-aac’ is full of problems… why is it used in audacity?
Despite the reasons you have to use this encoder, will be better if you put some advice (or warning) in the ‘help’ section. Also, audacity must no show options can’t work (image 3).
From my point of view, I strongly recommend you to change that encoder. The faster, the better.

Thanks for your program, I’ll use it when having audios different from 6ch (or more).

Because that is the encoder that is used by the group that build the FFmpeg libraries for Windows that we recommend. They are the only group I am aware of who offer pre-built FFmpeg for Windows.

All the AAC encoders have some problem or weakness where they are not as good as the others: Encode/AAC – FFmpeg.

Yes I have made a note to look into that.

That would be a (low priority) but probably quite involved programming task. Generally Audacity does not know whether the encoding will succeed until it tries it, and when it fails it does give an error message.

If a later version of libvo-aac supported more than two channel export, then Audacity would have to check the FFmpeg version in use in order to throw a warning before trying to encode.


ok, good luck Gale.


Very useful thread!

If you got ffmpeg error 2 like I did then you need to supply the whole path to ffmpeg on the command line.