Export Selected Audio resets the selection

I am using:
Windows 8.1
Audacity 2.1.2
I installed it using “audacity-win-2.1.2.exe”
also I installed “Lame_v3.99.3_for_Windows.exe”
and “ffmpeg-win-2.2.2.exe” (as I needed to work on m4a files)

The problem I am facing is that when I use the selection toolbar to select a portion of the track, and then I go File menu > Export Selected Audio… 4 out of 5 times, it will select everything (from 00:00 till the end) at the point where the Save As window comes up. And then I will have to go back and do it again until it works.

I didn’t use to have this problem before so not sure what has changed apart from re-installing Lame, and installing ffmpeg. I re-installed Lame by mistake, but can’t imagine this is the culprit. Most probably it’s ffmpeg (if at all).

Please note that I make a selection by using the selection toolbar and not the mouse.

Cheers.

I think you are clicking in the grey background below the track before export, or pressing ENTER when the track has the yellow focus border, thereby deselecting the track and causing there to be no selected audio. If the default Tracks Preference “Select all audio in project, if none selected” is enabled this will then select all of your track when you export.

If you disable that preference and you deselect the track then Export Selected Audio will be greyed out and you won’t be able to export, but at least you won’t lose the selection. In the next release of Audacity that will be the case whether that preference is enabled or not.


Gale

Hi Gale,

Unfortunately I am not doing any of these, and I’ve been able to perform this function before without any problems. What I’ve noticed however is that as soon as I’ve disabled “Select all audio in project, if none selected”, I lost the ability to “Export Selected Audio” (see screenshot). I believe it thinks that nothing is selected.

Thank you
No Export Selected Audio.jpg

According to your image this is correct. Nothing is selected in the track. Look in the blue waveform at 26 minutes, and you’ll see there is no grey colour in it). To fix it, hit ENTER on your computer keyboard. This toggles selectedness in the track that has the yellow focus border. So in your case where you have deselected the track, ENTER will select the track, changing the panel to left of the blue waves from cream to grey, and showing the selected audio as a grey area in the waveform.

If this is too difficult, you could CTRL + B to label the selection, then File > Export Multiple… by labels. This will export the labeled area.

Also note that the upcoming 2.1.3 version will grey out Export Selected Audio if nothing is selected, irrespective of the “Select all audio…” preference.



Gale

Ok, thank you for your prompt response. In the meantime I’ve re-installed it and it seems to be working better for me. Not sure if I’m doing anything differently but it seems better now, thank you.

Unless you used the EXE installer and enabled the “Reset Preferences” box half way through installation, reinstallation wouldn’t change Audacity settings at all.


Gale