Export Preferences

I tried to designate a default directory for export, but it isn’t working. I’ve tried quitting and restarting Audacity, as well as rebooting the whole machine. The designated path is visible in the preferences pane, but does not show up in the export dialog. I’m running OS 10.13.6, if that matters. TIA for any insight you can provide.

Testing on W10 with 3.4.2 I cannot reproduce this.

Preferences

Export
image

So this may just be a Mac issue -I can try to test this later today on my Macbook Pro if I get time.


There is one bug with the Directories settings that I know about but that only affects Backup Project:

Backup Project fails to honor the setting for Saves in Directories preferences #4950

Peter.

@Lrpom

Testing on my Macbook Pro macOS 12.7.1 Monterey

I cannot reproduce this on Mac either - works fine for me:

Peter

Thanks for looking into this, Peter.

After reading you couldn’t reproduce this on Mac OS, I dug a little deeper. In no particular order of importance, I determined the following:

  1. the default directory problem doesn’t occur when designating defaults for any of the other operations, “Open,” “Save,” “Import,” or “Macro Export;”
  2. I’m running OS 10.13.6 (High Sierra); and
  3. the default directory problem for “Export” occurs on all iterations of Audacity 3.4.x, but on no previous iterations of Audacity 3.3 (IIRC, this feature was introduced during the v.3.3 lifecycle).

I also verified that Audacity 3.4.2 was installed using the Intel-only dmg. My only guess is that there’s some bug concerning only the “Export” field when running Audacity 3.4.x on OS 10.13.6.

Anything you can figure out would be appreciated. I can work around this minor inconvenience, but it really becomes irritating when I need to export many clips and only a few need to go somewhere other than the default. Thanks again for all your help!

@Lrpom

sorry, but this leaves me totally foxed, I’m just a humble user (who does the odd bit of testing) these days.

My only suggestion is that you can log this as an issue on Muse’s GitHub issues log:

You will need a GitHub account for that but those are free.

Peter.

This topic was automatically closed after 30 days. New replies are no longer allowed.