Export not working [SOLVED]

Suddenly have this problem:

Loaded an mp3 file (I’ll call it 1.mp3) , changed the Tempo, and exported it with new name (1-slow.mp3). Looking at files using Krusader double pane file manager or the native File Manager, the only file in the directory is 1.mp3, the new one is not there. Close file, click “Open” in Audacity, the only file is 1.mp3.

Re-open 1.mp3, click on “Export”, and in the list of files is 1.mp3 & 1-slow.mp3. So, “Export” it again (1-new.mp3). Shows it exported. Close original file. Click “Open”. ONLY 1.mp3 is there. Load it. Click on “Export”, directory opens up and shows 1.mp3, 1-slow.mp3, & 1-new.mp3 as existing in the directory.

Using Krusader double pane file manager or the native File Manager, the only file in the directory is 1.mp3. But, every time I load and attempt to “Export” that file, Audacity shows that the previously exported files are in the directory. Up to 9 of them so far! BUT, they are not there!! :question:

The original file was sent to me and was saved on Apple iTunes. Perhaps this is the problem? Thinking that might be the case, I tried saving it in the .aiff format that it wanted to be in. Nope, still not there. But shows up as being there when I try to export again.

So, opened another directory and tried other .mp3 files in Audacity, some of which I created on this Linux box. Nope…

Audacity is not saving files. :astonished: ??? Kinda defeats the purpose of having the program!! All else seems to work just fine…


Running Xubuntu 14.04 LTS 64bit, Audacity 2.1.2

How very weird.

Where did you get Audacity 2.1.2 from?
What is the exact, full name of the directory where you are exporting the files?

Have you enabled “show hidden files” in your file browser?

When you enter the name for the file, are you “typing” the entire file name including the file extension? (rather than appending / prepending the old name, or pasting the name).

Try opening a Terminal window, navigate to the appropriate folder. then list the files in that folder. Are the files there? (if you’re not sure how to do that we can give step by step instructions).

What happens if you try to open the “non-existent” files from the “Recent Files” option in Audacity’s “File” menu?

When you use File > Open… in Audacity, ensure the filter is set to “All Files”.

To check if the exported file exists, open File > Export Audio… and drag the exported file from the Export dialogue into the Audacity window.


Thanks for the replies. Let me see if I can figure out how to explain this…
First, it appears to be fixed! I got the 2.1.2 version from the Audacity website (was running 1.5). D/l it, went to Synaptic Pkg Mgr, and installed it. Did the view with Terminal, only the original file is there, so is very weird that Audacity is seeing all the others, yes?

I keep all of my music files on an external hdd… May genre sub-dirs, backup tracks, instructional, self-recorded, etc. & I have modified many files in these dirs over the years, never had a problem. So, today I copied the file to my home dir, altered it, saved it, and ‘poof’, it’s there! Copied the original to another ext hdd… altered it with Audacity, and it saved it fine.

So, ran chmod on the ext hdd, loaded, altered and saved the file, and now it’s working again, and the other “ghost” files that I’d created and were seen by Audacity are not there, only the original and the newly made copy.

Guessing that something changed permissions on the hdd (I’ve had this happen before, weird as that is), and now that I’ve re-set the drive to full permissions for myself, it seems to be “normal” again.

<grouse & bitch> This is my one gripe about Linux… I’m the only user of my system, but I have to fight to have & keep control of “stuff” on my own system! Retired NT support, Paradox/Access programmer, etc, I am.</grouse & bitch>

Again, thanks and we can mark this one solved!

Just to be clear for others, the Audacity site http://www.audacityteam.org/download/linux only directly provides source code for Linux. I am guessing you got the Ubuntu Handbook PPA version of Audacity 2.1.2 which we link to.

There has never been a “1.5” version of Audacity.