Export Multiple exports silence from multi-track project


I have a three track Audacity project. Source files are arranged sequentially - originally this was one recording session but every interruption did yield a new file. Single source files are ca 02ː04 hours,14 minutes, and 46 minutes.

When I try to export parts based on labels I created, Audacity creates abnormally huge files - A sound clip of 5.334 seconds duration marked by a label is exported as a file with a length of 01ː15ː35 hours, of which the first 5.334 seconds are the actual sound clip with the rest being silent.

The same applies to 5 labels within the same project - all start out with the actual sound clip with a large silence following. I can’t explain for the duration of the silence - it seems neither the remaining duration until the end of the project (which is 02ː02ː12.108 hours, nor the duration until the end of that track (which is 01ː01ː15.165 hours).

The behaviour seems to apply to all multi-track projects and across various export formats, however it had not been present in earlier versions of Audacity (I had already exported based on labels some of those I tried now and there was no silence introduced originally).

I have been using Audacity for years and it is the first time I encounter this behaviour. Exports from other single track, multiple labels projects are as expected without silence. I assume some default setting has been modified or newly introduced or this is some sort of misbehaviour/bug.

I’m using Audacity 2.1.1 on Windows 10.0.10586 64bit.

Thanks for the support.

It’s a known problem that started in 2.1.1.

To solve it, Export Multiple based on tracks and don’t use labels, or Export Multiple based on labels and only have one track. To make one track, Edit > Select > All then Tracks > Mix and Render.


If you only have a few songs, you can Export Multiple then open the files with the long silence, delete the silence then save with the same name. This temporarily used quite a bit of disk space until you re-save and delete the .old files the overwrite creates, but got the job done for a few songs until the fix arrives.

A better workaround is to export based on labels only for a single track. If necessary, select all (Ctrl+A) then “Tracks > Mix and Render” before exporting. Ctrl+Z to undo the “mix and Render”.