I just exported ALL tracks (a rhythm track and horn tracks) from a project in Audacity to import them into another package.

The rhythm section track plays fine - it starts at time “0” and plays perfectly.

The other tracks are all off by a fraction of a second. These are horn section parts, which don’t enter until the 1st chorus.

Audacity seems to drop a small amount from any track that has dead space up front. (?) But I even tried pasting in some sound to the front of the other tracks - they all are aligned and play perfectly in Audacity, but when exported, any of the tracks that had dead space up front are ALWAYS off when imported into another package.

This definitely looks like a bug in Audacity. It should just be math, rigtht? Tracks should export with the exact same time as each other, no?

How can I take recorded tracks and reliably export them to another package?

Audacity seems to drop a small amount from any track that has dead space up front. (?)

Are you using MP3 or some other lossy format? If so, try WAV. This is a known characteristic of MP3.

If you want MP3, export ONCE as MP3 as the last step.

Which version of Audacity?
Do any of the tracks have empty space at the start?
Do any of the tracks have sound before time=0? (indicated by small left pointing arrows at the start of the track)

OK… this ended up being a problem with the target system, NOT Audacity.


I had to turn off a “default” preference in Ableton. From there online FAQ: “Turn off Auto-Warp Long Samples. This is important to ensure that start markers line up exactly at the beginning of the audio files - even if there’s silence at the beginning - and that no warping or audio degradation will occur. Also turn off Create Fades on Clip Edges, otherwise clips with a sharp attack (eg. kicks) will have that attack slightly muted on the first beat”

So… score 1 for Audacity, 0 for Ableton (strikes me as being a silly default).


Sorry for the false alarm!

No problem :wink:
I’ll close this topic as “solved”.