Export Audio only allows AIFF [SOLVED]

Audacity 2.1.1 on OSX 10.9.5

When I try to export audio, there is only one option in the Format dropdown list: AIFF (Apple) signed 16-bit PCM

What happened to the other options? (…or is the dropdown list not functioning? Clicking on it does nothing.)

So you don’t get this listing (attached - scroll down)? This is Audacity 2.1.1 on Mac OS-X 10.9.5.

Did you actually install Audacity, drag the Audacity program folder into your /Applications folder? You can get some really strange actions if Audacity isn’t really installed and is running from inside the .dmg file.

Koz
Screen Shot 2015-12-19 at 19.36.41.png

I guess you have used Retinizer on Audacity which causes this issue. See https://forum.audacityteam.org/t/retina-display-issue/39036/1

If so it would be very helpful to us if you could use “Audacity 2.1.2 RC1 (for testing)” from http://www.fosshub.com/Audacity.html/. That version is built with a later version of wxWidgets. It is possible in that version that either Retinizer does not cause the export choice problem and/or Retina support may be better without having to use Retinizer.


Gale

As I said, I get no list. Audacity is running from Applications. (in Audacity folder with all support files)

I’ve been using Audacity for years on Linux, Windows and Mac without this problem. The first time I noticed this was a couple versions ago. I thought it was a bug that would be quickly fixed in a newer version, but if nobody else has this problem then it must be something specific to my setup. I think I’ll wipe everything Audacity from my computer and re-install.

Yes, you’re right! I’ll try 2.1.2 RC1 and see if it’s fixed. Otherwise I’ll just not “Retinize” it.

Thanks!

I just tested with 2.1.2 RC1 and have no problems with the Export list. I also de-Retinized 2.1.1 and that works too.

A couple minor things I noticed with 2.1.2 RC1: the left panel is fuzzy (not “retina”), some of the other text is way bigger than before and it seems you can no longer drag an audio file to the application window. (just to the application icon)

I’m just mentioning it though, not complaining. :smiley: My problem is solved. Thanks again!

OK thanks, I closed the bug report that we had open for that.

This is with Retinizer off? And is this the Track Control Panel? Is it all fuzzy, or just parts of it such as text?

The Timeline text is too large on all resolutions. Can you point to any other text that is too large?

Yes thanks - we have a bug open for that http://bugzilla.audacityteam.org/show_bug.cgi?id=1236.

Thanks for the response.


Gale

Well actually, Retinizer won’t allow you to “retinize” 2.1.2 RC1 because it says “App already retina capable!”

Here are some screenshots:

Audacity 2.1.2 RC1:


Audacity 2.1.1 “retinized”:

Audacity 2.1.1 (NOT “retinized”):

In all cases, the left panel is fuzzy.