Export as MP3 fails for unknown reason / infinite process


Anyone else experiencing problems while exporting sounds as MP3 files?

Audacity 2.1.1. permanently gets stuck during export: After 30 seconds the progress display is showing a remaining time that’s steadily increasing, up to ten hours and counting. Obviously Audacity has stopped the export process at that point. No error alert at all, though. :cry:

Ideas on that?

Thank you!

– Mac OS 10.9.5 (13F1112) –

What did you call the export name? If you used slash marks in the name (like in a date), Audacity is looking for a folder that doesn’t exist. Use no punctuation marks at all in your filenames except underscore.

It’s also possible it’s trying to export work to a full hard drive. That will take forever, too.


Actually, the name contained dashes (not slashes). Erasing them doesn’t change a thing. The HD has 600 GB free. :neutral_face:

Are you exporting to the HD or to somewhere else?

Is the folder you are exporting to buried deep within numerous subfolders, so the path to the file has a very long name?

What happens if you export as WAV? You can convert to MP3 in iTunes.


I was exporting to the internal SSHD, onto the desktop—no hassle with long paths.

It must be a problem of this Audacity build. I’ve tried exactly the same steps with Audacity 2.0.2. and it worked perfectly.
Didn’t try the WAV export yet.

So why does no-one else have this issue?

Where did you get Audacity 2.1.1 and the LAME encoder from?

I would recommend quitting Audacity, then using Go > Go to Folder in Finder, and enter:

~/Library/Application Support/audacity/

Delete the “audacity.cfg” file and restart Audacity.


A Fusion drive? Or a very big SSD?