Errors in data file names in an .aup file

I recently saved a project on my laptop (Audacity 2.0.5, windows 7) and when I opened it again the error dialog said it had 2 missing block files. One of them ended with “”, and removing the extra “.au” fixed it. The other file name was “”. I was able to find the correct file by letting the file open proceed to “orphan block file” and changing “” to that name. I have no idea how to make this happen at will, but I figured I’d report it anyway just in case knowing this can happen along with some other random clues from other sources might prove useful. The two errors weren’t near each other in the project and the correct files were in different sub-folders. All I can say for conditions is that I had previously saved the project, closed Audacity, then recorded another one, closed Audacity, opened the first one, did some editing, saved it and closed Audacity. Both projects had stereo tracks. The errors must have sneaked in that last time I saved the first project. I’ve recently installed a new antivirus, “Bit Defender”, and a mess of Windows updates, for what that’s worth.

Am I mistaken or have you had weird problems like this before?

It’s probably but it’s very hard to fix errors like that which occur so rarely and randomly.

If you have the Audacity installation directory or project directory open in a file manager like Explorer, or are monitoring those directories with security applications, this probably increases the risk that Bug 137 will be triggered sooner or later.


Quotes below are from the ‘Bug 137’ report:

“Usually errors are associated with multiple projects open at the same time and Audacity putting blockfiles in the wrong _data folder, or with a project that has multiple “d*” folders inside “e00” and Audacity putting the .au file in the wrong subfolder.”

This may have been the “weird problem like this” that I’ve had before. While multiple “d*” folders under e00 are the rule rather than the exception with my projects, I now avoid having multiple projects open concurrently for this reason.

All of the manifestations of “Bug 137” described in the Wiki involve things happening to the .au files. What happened in this project was corruption of file names in the .aup file. One file name was changed to “” and another otherwise legitimate one got an extra “.au” appended.

“Audacity has also occasionally been found to move, rename or delete .au files within the current _data folder when re-opening the project, thus creating orphans and/or missing files.”

I’m not sure whether, in my previous “weird problem”, the files were renamed or in the wrong folder, but their names didn’t match those in the .aup file. In every case so far I’ve been able to recover the project by editing the .aup file as long as I hadn’t let Audacity delete any orphans.

I hadn’t mentioned this previously but will now to eliminate a potential dead-end avenue of inquiry: I discovered the errors in this project after copying the project to my home computer and opening it there. I then examined the original .aup file on the flash drive and then on the laptop with a text editor and found the same errors. This would eliminate anything associated with opening the project - it had to have happened when saving the project.

“Sometimes edits at the end of a track are implicated, sometimes cutting/duplicating whole tracks to new projects (or to new tracks within the project).”

The edits I had done as of the time I had the problem were deletions of noise impulses, replacing some strings of them with a copy of pure background noise, and using “Pop Mute” to suppress those occurring during speech (we’d had an electrical problem with one mic used only for speech). None of these were at the end of the track, nor were the block files near the edits - the offending mic was not in use through that part of the recording. For replacing a string of impulses with pure background noise, I duplicate a nice long sample of relative quiet once, and use appropriate length portions of it wherever needed.

Just to eliminate one more suspect, I ran a file system check on the laptop in case it had cross-linked files, etc. No problems found.

This could be a side-effect of Bit Defender, then? Too bad Bit Defender has no user settings for skipping certain folders or file types.

OK I clarified that on the Wiki page.

Yes, understood. The user sees the problem when reopening the project but I suspect the problem almost always happens in (or when quitting) the last session.

Does Bit Defender have an option to trust or ignore applications?


Which happens to be the main typeface for Bit Defender…

I’m not saying that means anything, but I’ve only seen seemingly random filename changes once in the last year or so and one of these files was changed to the name of a typeface. That wasn’t with Audacity, but a database app in FM Pro. IIRC on Win 7.

Did you have these errors before you installed Bit Defender?

Did you try upgrading Audacity to the latest 2.1.0?

If it does, I haven’t found it. Not likely it does, since one of their advertising points is that their program doesn’t leave any decision-making to the user. I picked it because the testers give it good grades and it doesn’t have nag screens.

No to both questions. If it happens again I’ll switch to my old favorite AV which I still use on the other laptop. They’ve added nag screens, but that’s easier to put up with than having to repair my project with a text editor. suggested that Bit Defender was preventing Audacity from launching.


Maybe upgrade Audacity first? Seems simpler than uninstalling an AV app, which is a bit of an adventure sometimes :laughing: