Error while opening sound device

Hi all! I’ve read similar posts to this, but none seem to match my specific dilemma.
I am using the Focusrite Scarlett 2i2 First Gen. It has been working flawlessly for 3 years now, and suddenly just a few days ago, it began to give me issues. The output audio is fine, and my windows 10 machine recognizes it fine, but when I open up audacity, the 2i2 makes a popping noise, and I get the classic error message, “Error while opening sound device…” I have never had this problem before, and I am thinking it has something to do with Windows, because the 2i2 works fine on my Macintosh machine. I’ve tried the following:

  • uninstall most recent Windows update
    -uninstall and reinstall the Focusrite USB 2.0 driver both for Gen 1 and Gen 2.

Also its worth noting that it doesn’t seem like this problem is specific to audacity because when I record game play, there is no audio in the recording.
I think my only hope at this point is for someone who has had the same problem, but any feedback is appreciated.
Thanks in advance!

If your interface takes driver software, it has to say “OK with Windows 10.” Just OK with Windows doesn’t do it. Win10 is a new OS and takes new software. Same with recording internal sound or Game Play. You need software or settings that are OK with Win10.

The 2i2 is a stereo device, so I would start out with settings of 44100, 16-bit, Stereo. That’s a plain universal setting that everybody should know how to use. Were you using a single microphone with the 2i2? You can run into some interesting problems by using the 2i2 in mono. That mismatch may be why it doesn’t work right.

Both Focusrite and Behringer make very nice mono microphone systems to get around this. Focusrite Solo, iTrack Solo

Behringer UM2 (the one I have) and the Behringer UMC22.

They were designed for a single voice or instrument and as far as I know, they will all do zero latency overdubbing.

This isn’t as wacky as it seems. In the most effects-heavy movie, almost all the dialog is coming from the center of the screen.


Hi! thanks for responding.
Within audacity, I have changed the record mode to both stereo and mono, neither working with the combination of the default sample rate of 44100. Normally, it works perfectly. I’ve had this thing since Windows 10 released, and it never gave me problems. I have no idea why it started now. If there is some sort of system setting I can try, please let me know.

Recording game play doesn’t bother me. That’s two sound programs running at the same time and Audacity doesn’t always do that so well. Does it record from the soundcard (external microphone or headset) with no game or any other sound program running? That’s a natural, intended connection.

We should wait for a serious Windows elf.


Yeah. It records any outgoing sound, or any incoming depending on the setting in the drop down in audacity. As far as recording gameplay goes, I use nVdia’s shadowplay, which records both audio and video, no external program needed. So that leads me to believe that there is a problem between WIndows 10 and my scarlett 2i2.

Also, its worth noting that it has begun not working on startup. What I mean by that is when I start my machine, and try to play audio, it does not play the audio. In order to fix that, I have to unplug and replug the 2i2 into the computer. It was not doing that yesterday… Is my 2i2 dying? lol

I have to unplug and replug the 2i2

I don’t have a 2i2, so I can’t give you hands-on “trick” diagnostics like I can with other equipment.

The behavior seems most unusual.

The earlier Windows machines had audio control panels which had to connect to the device before Audacity sees it. Drill down to those panels and see if the device or its driver appears. Leave Audacity closed.

Force it to work (replug), restart the machine without replugging, drill down again and see if it’s different.

I think you can get to the sound control system by right-clicking the speaker in the lower right.


Just a little update for anyone interested. I plugged in the 2i2 into a USB 2.0 port instead of 3.0… I was able to record gameplay with sound. (Very happy about that) However, when I open up Audacity, I get the same error message I always do when I hit record… Error opening sound device etc…

That’s not so unusual. Whether the device works or not on boot depends on the order that things initialises. If the sound system tries to use the device before it has initialised, then the device will fail and Windows will then decide that it can’t use the device.

According to the specifications, the Scarlett 2i2 is a USB 2.0 device
Does the device works straight after booting when plugged into USB 2 port? It would not surprise me if the USB 2 port initialises earlier than the USB 3 port.

There may be a clue if you look in Audacity’s “Audio Device Info” (in the Help menu).
Note that there are two different “Error opening sound device…” messages. The full error message tells you whether it’s the recording device or the playback device that has the problem.

This most recent Windows Update has solved it. Just as suddenly as the audio interface stopped working, it suddenly started working again after the update. I have no idea what changed, but I am very thankful to the developers of this most recent update. And to everyone who answered my initial question, thanks for all your help! :smiley: