Error while opening sound device

I have been using Audacity 1.13 for some time with no problems. Today, for no apparent reason, I am now getting this message. So, I have downloaded Audacity 2.0.3 but still get the same result. I have also read the other entries in the forum on this topic - but - I don’t even get an option to choose an ASLA device, whatever that is. PLEASE HELP - I’ll be lost without this program! By the way, I also use VinylStudio to monitor the music as it is being played, in conjuntion with Audacity, and have downloaded a new version of that program, but can see no changes apparent in preferences

You’re going to have to fill in the holes. What Are You Doing? In Detail.


System software is Windows Vista Service Pack 1. Using Audacity 2.0.3 to record LP’s. When I am playing the LP’s (on a standard record player), I pass the signal thru an NAD digital preamp, and this is processed by some software which came with the preamp called VinylStudio (version 8.5.3). This version was only downloaded today. Prior to downloading the new version, I was able to record (and listen to the music via speakers) using the check level feature in vinyl studio. After recording, I could listen to the recorded stuff immediately in Audacity, without changing any speaker (playback) settings. My current workaround is to continually chop and change the playback option in vinyl studio after recording and before playback, and vice-versa when I want to record some more, which is a real pain. Since posting my original request, I have discovered that all this chopping and changing also prevents me playing back music in iTunes. I’m now so confused that I have no sound at all, from any application. I am not a technophobe (or whatever its called), I’d just like to get back to the happy little situation which I had previously where everything worked. So please, if you can offer a fix, please do it in laymans terms, and I’ll be forever grateful!!

Then an obvious thing to try would be to revert to the previous vinylstudio version or don’t use it.

You can see the level in Audacity before recording by clicking in the Audacity red recording meter. If you want to listen without recording, then as well as clicking in the recording meter, choose Transport > Software Playthrough (on/off) and if it is not checked (ticked), click it to do so.

This is not Audacity’s fault. Does this new VinylStudio version show as a playback or recording device in Windows Sound or in Audacity Device Toolbar ?

Did the previous version do so?


Try unchecking ‘Use WASAPI for playback’ in VinylStudio’s Change Playback Device dialog. This requests exclusive access to the device.

PS: By the same token, you may also need to uncheck ‘Use WASAPI for recording’ in VinylStudio’s Check Level dialog.