Error while opening sound device (WASAPI)

Hey everyone, I am trying to record my PC’s audio directly through Audacity. I used to be able to do this using stereo mix but after some googling it seems that when using a USB headset, you can’t use stereo mix anymore. So the solution offered was to try and use WASAPI because it would allow you to do this. When I hit record I get this error

What do I need to do to get this up and running?

I am using a Logitech G430 Headset
Windows 10
and Audacity 2.1.1

We could use a goal, here.

“I want to record my voice and Game Audio.”

“I want to record my voice and a Skype interview.”

Did I hit it?


My goal is to just record system audio. Meaning whatever is coming into my speakers. Not really my microphone or anything to that effect but more game audio, or audio from someone else’s microphone sure. That sort of thing. I used to use stereo mix as the input in audacity but I can’t do that anymore since I have this USB headset. So i’m wondering what the alternative is

VoiceMeeter constructs a virtual mixer in your machine. That may help.


more game audio, or audio from someone else’s microphone sure.

I only mention that because those two take special purpose software.

Skype works well with Pamela and Games can be recorded with FRAPS.


I usually just used audacity as an all-in-one for recording what I am currently hearing, it seems to do the job for that. I only ask if there is something simple I am missing that is causing this.

I believe i’ve used a similar software as this for another issue I had trying to sync audio before. Is there no simple alternative that wouldn’t require a download or install of any kind? I’m just wondering as to why WASAPI works fine for most people but it throws this error for me

We published a Self-Recording document for Windows. See if there’s anything in there.

Most gamers, producers and performers would kill for a simple way to record everything.


But as has been said a few times, not on Windows 8 or 10.


You may have to change Audacity Project Rate at bottom left to 44100 Hz, or to whatever the current Default Format rate is in Windows Sound. To check Default Format, right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click the USB headset, choose “Properties”, then look at the “Advanced” tab. Or you may have to enable both Exclusive Mode boxes just below Default Format, in which case Default Format sample rate should be ignored. Simply choose 44100 Hz or 48000 Hz in Project Rate bottom left of Audacity, which should work on most headsets.

Restart Audacity after making changes in Windows Sound.

When you receive the error, what application is producing the sound that you hear in the headset? If it’s a game producing the sound that demands exclusive access to the sound card (your headset in this case), then you will receive the error opening and you won’t be able to record. Perhaps try it playing audio with a web browser to see if that works.


The problem is that i’m not trying to record the headset microphone. I am trying to record the actual sound which is a playback device in windows. WASAPI will allow you to use speakers as an input device it seems, but not for me. My default sound format is 48000HZ on all of my devices, so I made sure to select that. Still not sure what else I can try/do. I could use an external app but it’d be nice if I could use default software and figure out why it is doing this. I’ve tried recording just a video playing in chrome and still it won’t let me.

I may have a clue.

I just visited the web site and it goes for multiple pages about how this headset is radically different from all others. Dolby 7.1 surround, Presentation controls on the cable, etc. etc.
Screen Shot 2017-01-15 at 8.13.04 PM.png

WASAPI will allow you to use speakers as an input device it seems, but not for me.

You’re not using speakers.
What happens if you stop using the headset?


I thought you were trying to record what you hear through the headset. If not, what sound device are you trying to record?

Try checking both Exclusive Mode boxes in Windows Sound and restarting Audacity.

Are you playing what they call 7.1 surround sound mode? Have you installed the Logitech gaming software? They may be some setting there.

Have you tried a different USB port? I hope you are connecting to an empty USB port and not a USB hub connected to the USB port.


Oh I see, so it might be a headset that just won’t do it. I am not using the 3.5mm jacks (which are referred to as speaker in windows sound) but instead using a separate speakers device (from the usb connection) which is what gets sent to my headset

I am trying to record what I hear through the headset yes, not my microphone or what I speak into it, but what I am hearing real time. That is what I want to record.

Yep the exclusive mode boxes were checked from the beginning sadly. I think it is in 7.1 surround mode yes, I did install the Logitech software and looked through it to see if there was anything that stuck out. It lets me record my microphone just fine, but not the actual audio coming into my headset (my pc’s audio)

Your microphone, near as I can tell, appears as a plain microphone. It pumps plain audio into the system and Audacity records the microphone. Piece of cake. Do you have an iPod or other Personal Music Device? Did it come with earbuds or other headphones? Try plugging those into the Headphone connection of the soundcard and unplug your fancy-pants headset. You may need to restart the machine after that to settle the software and drivers.

I’m not suggesting you do that forever. If this starts working, that can give us a clue where the system is falling over.


Generally speaking, Windows WASAPI loopback records fine from USB headsets. Stereo mix cannot record from USB headsets because stereo mix only records what is playing through the built-in sound device.

I don’t think WASAPI can record 7.1 sound or anything pretending to be that. Try turning that off.

You could also open Help > Audio Device Info… top right of Audacity and save it to a text file. Attach the file thus:
How to attach files to forum posts.


Basic troubleshooting. Divide the system in half and/or reduce complexity until it starts working.

If basic headphones fails, then there may be something basic or more serious wrong. Everybody thinks that should work, no question.


Right yeah, if I were to unplug my headset and just use plain old audio through the motherboard that will always work. I’m just wondering if there is something I can do to record while listening through USB headset. Essentially, is there a stereo mix equivalent with a USB headset?

Indeed, like I said if I use 3.5mm I can just use stereo mix as before, it’s only this headset (something about going USB/digital made this not work) that is unable to record.

Yep, after some reading online I figured that you could not use stereo mix unless it was a 3.5 mm connection. I just tried to disable surround sound and it seems to have the same issue still.

I have attached my deviceinfo below.

Again thanks for the help both of you I do very much appreciate it.
deviceinfo.txt (7.98 KB)

Motheboard…always work.

It’s good to know that earlier. So the fancy headset is the only thing that fails. That gets it straight down to headset-headphone management.


Precisely, I was able to use stereo mix just fine. Somewhere along the line of this headset and using USB there’s an issue that i’m not sure about. I googled basically how to replace Stereo Mix with something else so I could record my PC audio in audacity, and it was suggested to use WASAPI as it would allow you to use such an input.

I think you phrased the question wrong. You want to record the earpiece sound of your [specific model number] headset. I bet all the handy, prebaked responses vanish.

One of our handy, prebaked responses is to make sure all your drivers and support software are perfectly up to date with your Windows.