error while opening sound device please check input and samp

Hello Everyone,

Approximately one week ago I used audacity to record one of my dj Sets from my mixer and turntables. Everything worked flawlessly and I had no problems. I was hoping to do the same thing this week and to my surprise i got the error “error while opening sound device please check input and sample rate”. I have not changed or messed around with any of the settings in audacity since i last used the program. I have spent about 5 hours now searching the web and trying all of the obvious things that people are reccomending. I am at a complete stand still as to what i should do in order to make this work so that i can continue to record my live sets for posting on my website.
I am currently using an external USB soundcard and as I have mentioned this set up worked perfectly the first time that I used it. Im not sure what combination of input/sound host settings I used but it worked for me and now no combinations seem to work for me.

Things that i have tried:
-Setting the project rate to 48000 HZ and 44100 HZ
-Changing the Audio host and input device to many different combinations
Restarting the program
-Checking the windows settings on my sound card and making sure they correspond with the audacity settings
-Trying an older version of Audacity
-curiously when i downloaded AVS sound recording software it detected my microphone input from my external soundcard but not the “Line in” channel. This seems to be the same with audacity. If i use the soundcards microphone input I am able to record in mono which is not what I want.

Any advice would be greatly appreciated.

I presume that you tried rebooting the computer?

Check in the Windows Sound Control Panel that the sound card has been detected by Windows, is enabled and working - If Windows does not see the audio device then Audacity will not be able to.

Thanks for the quick response. I have checked the windows sound toolbar and made sure to enable my external sound card and set the line input from it as the default recording device. I will try to get some screenshots together for everyone to see, maybe that will yield some more information for you.

I presume that you tried rebooting the computer?

Sometimes you can do a world of good just by making Windows rengotiate its hardware.