Error whenever audio is recorded [SOLVED]

I’m using the latest update of audacity for Mac OSX version 10.9.5, (2.1.1) and I have a recurring problem of whenever I press record.
It works for around 2 seconds, then the whole entire application freezes or crashes completely
I’ve deleted audacity and reinstalled it many times, I’ve also gone to yahoo answers for help, but to no avail.

So if you can provide any, thank you so much for helping.

Thanks for the version information.

What are you recording and how?


You are actually installing Audacity, right? I think the latest version has a little draggy installer thing. The earlier ones didn’t have that.

Also a note. Reinstalling Audacity doesn’t reset Audacity. To drag Audacity back to factory-fresh you have to reset it.

Close Audacity.

Go (top of desktop) > Go To Folder > ~/Library > Application Support.

Drag the audacity folder to the trash. Start Audacity. You should get the fresh welcome screens.

I make it a point to save copies of all my custom installed filters, effects and modules away from the Audacity structure because of this. All your installed filters are going to go away. Factory-Fresh, right?


I’m recording voice-overs and just plain speaking, stuff like that.
I got a recording of what happens if it helps at all.
Also, one more thing. I deleted the .cfg file and tried again, but it still had the same exact problem.

Have you got Transport > Sound Activated Recording recording checked (ticked)? It looks like it given the Pause button comes on an off. If so, untick Sound Activated Recording, because that type of recording may crash 2.1.1.

If that isn’t the answer, drag the Audacity folder for 2.1.1 to Trash and install 2.1.2 RC2 (for testing) from near the top of 2.1.2 has a fix for Sound Activated Recording crashes and might solve any other issue you have.

Let us know if you still get recording crashes in 2.1.2 RC2.


That worked. Thank you so much.