Error when opening up project [SOLVED]

I am using Audacity 2.0.6 and here is my problem.

Error opening project
Error: reference to invalid character number at line 6.
I was recording a track on audacity when I ran into this problem. I am a bit devastated considering that I had worked hard on the recording and I have been looking for solutions all day.
I’ll attach the file down below. If anyone is willing to help, then that would be very much appreciated.
Thank you!
day dreaming.aup (22.2 KB)

There is one or more invalid character(s) in the “description” metadata tag.

The first thing that I would suggest is that you update Audacity to the current 2.1.2 version and see if that can open the project.
(also a good idea to make a backup copy of the AUP file and the project “_data” folder and put them somewhere safe).

Make sure you copy the AUP file and _data folder to a different folder than the folder they are in now. Or safer, use File > Save Project As… .

2.1.2 won’t open the project either. We decided not to handle control characters, HTML entities and similar in the AUP file due the risk of Audacity crashing. The solution would be to remove those entities (they start with &# and end with ; ) by following

However I have done this for you in the attached which you should now be able to open.

day dreaming.aup (22 KB)

Thank you Gale! Your efforts are very much appreciated in regards to making the file work but also in teaching me more about Audacity. Thank you once again for your efforts are really appreciated.