Error when I try to record stereo through my 8ch device

Hey all! New to the forums.

I’ve decided to post here because I’m unsure if there’s a way to help out with the problem I’m having. It’s no hassle aside from the amount of audio tracks. Before I get into this, I’m using Audacity 2.1.3.

So my issue is that I have an 8 channel audio device. My headphones have drivers that lock down the device settings in my Playback Devices (Locked at 48KHz, 8 channel). While using all 8 channels is optional via the virtual surround setting, the device will always be on 8 channel mode (Meaning it just transmits to L/R when it’s off, all other channels are silent). This can get annoying when I’m trying to record system audio because I must have audacity set to record all 8 channels. Attempting to set it any lower will throw an error stating it couldn’t open the sound device. While this is no major issue, it can get to be a hassle to constantly delete the 6 unused channels then merge the L/R channels into a stereo track for every thing I record. Is there a way to make it so that I can only listen to my L/R channels and record as a stereo track? (I say again, just for emphasis here: I can not change the device setting for the amount of channels. It’s hard-locked by the drivers.)

Thanks. If you need any more details, just ask.

This is expected behaviour. You need a more flexible device.

You can try Windows Direct Sound host in Device Toolbar instead of WASAPI, but it probably won’t help.


You don’t need to delete the extra channels or convert the used channels into stereo, Audacity will do both of these when you export. The other channels are flat, so they don’t contribute to the file size. It would be nice if there was an option to fit the tracks to the work area though. They get a bit squished.

There is the Automatically fit tracks vertically zoomed Preference.