Error: Unable to open Target file for writing

I am using Audacity 2.1.0 on a Mac running Yosemite (10.10.5)

I am trying to Export Multiple mp3 files w/ labels (17 songs), which I have done successfully in the past. Now however, Audacity exports the first 6 songs then I get the error message “Unable to open target file for writing”. I have tried several times, in different file locations(desktop, a flash drive, cloud storage) and have also tried switching to WAV format.

I tried deleting the first 6 songs and exporting the remainder, but that went immediately to the same error message.

Any thoughts on how to get around this and what might be causing the problem? :cry:

You can get that error if you put punctuation marks in a filename or sometimes the labels. This typically happens with dates. 10/14/15 may look like the current date to you, but to the computer is looks like a filename and two different folders. It’s best to use the ISO version of dates 2015-10-14 is now. Dashes and underscore are OK.

Your problem could be something else, too. but that’s the most likely.


It is most likely that you have the slash character in the label for the seventh song. If so, change it so something else, perhaps a dash.
– Bill

For me, my antivirus program Avast was the problem. I had to tell Avast that Audacity has permission to write to a protected area.

If you have tried the above suggestions with no favorable results there is something else to try:

Sometimes, when Audacity encounters an internal read error while trying to write to a user designated file, Audacity can misleadingly report it as a write error. Try using Ctrl+A, Ctrl+C (or Mac equivalent) to select-copy all your tracks, Ctrl+N to start a new Audacity session, then Ctrl+V to paste the tracks into the new session; if you have errors here then try narrowing down the copy range. Then try doing your export.

And do post back if you get something to work so we can use that info to help others.