error R6034

Hello, first-timer here :smiley:
I use audacity version 2.0.5 on a windows vista machine. Recently I installed VST plugins into my audacity plugins folder. After the installation, on clicking any of the new effects on audacity, I got an error message about the cfg.xml needing an update. I then ensured that I placed this cfg.xml file in my plug-ins folder, after which the error message stopped. The problem now is that whenever I launch Audacity, I get an error message: ''R6034
An application has made an attempt to load the C runtime library
incorrectly.
Please contact the application’s support team for more information".
Please, what do I do now? I’d be very glad to get responses here.
Thanks

Remove the plug-in for which you added the cfg.xml. Which plug-in is it exactly, with the web address?


Gale

Hello Gale,
It was the freeverb3cfg file I moved into the plug-in folder. This solved the initial problem. But I’m glad to let you know now that the error R6034 message has stopped. What I did was I moved the msvcp90.dll and msvcr90.dll files out of the plug-in folder to the Audacity directory C:> program Files (x86) > Audacity. This solved the problem. No more error message.
Thanks for your help.

OK I guessed it might be freeverb 3. But generally you do need to install configuration files or folders that belong to the effect into the Plug-Ins folder, as well as the DLL file(s).

OK but that problem (I assume) was down to you. :wink:

The wx* and msvc* DLL files and the “Microsoft.VC90.CRT.manifest” should stop in the top level of the Audacity installation folder.


Gale

Absolutely :slight_smile:. Thanks