Error Opening Sound Device

Hi - New here and looking for assistance. Trying to record from USB turntable. Windows 10 Version 1803 (Build 17134.228). Audacity version 2.2.2.

Read all guides, tried everything, still receiving the same error message whenever I hit the Record button. I must be missing something, any assistance appreciated.
audacity settings.png

What is the exact and full error message?


Please see this page in the Audacity Manual:


Tried all that WC. Sample rates, recording channels, etc, all match up. Changing Preferences options made no difference.

I am running a dual boot system, Windows 8.1/Windows 10. Booted into Windows 8.1 and tried again, using the same settings, all good, no problems recording in Windows 8.1. Switched back to Windows 10, same error message. Seems some setting in Win10 is not quite right but, for the life of me, I can find where or which one it is.

Guess I’ll just stick to recording in Windows 8.1. Thanks for your reply, appreciated.

In Windows 10 (since a recent Windows update), you have to give permission for applications to use recording devices. See:

That did it Steve, THANKS!

I would never have thought of that.

Yes, Steve! Thank you! I would use many exclamation points here, but that is quite lame (not like the plugin). Like Brightspark and the others, I have been checking and re-checking all the settings, to no avail. Nobody would have thought to check the Privacy and permission settings for Microphone after not having an issue until the latest Windows 10 update. Well, maybe not “nobody,” but not many. Thank you, thank you. I should have checked this forum before spending all morning frustrating myself with this issue.

I have added a section regarding this to the upcoming 2.3.0 Manual - unfortunately we are unable to update the already released Manuals.