Error opening sound device...

Hi,

So there have been a lot of posts on this, but no solutions as yet for me…

I’ve tried everything @ http://manual.audacityteam.org/o/man/faq_errors.html#Why_do_I_get_.22Error_while_opening_sound_device.22.3F

Basically either after pressing record or 2/3 minutes of recording, the message pops up. [Error while opening sound device. Please check the input device settings and the project sample rate]

This also completely shuts down all sound functionality on my laptop… but will normally right itself after a reboot.

I’m recording via a pretty basic Logitech microphone and using an “IDT High Definition Audio CODEC” as a sound controller…

Any advice?

Is that a USB microphone or does it plug into your sound card?
What settings do you have in the Device Toolbar?

It plugs into the sound card.

Device toolbar is currently @ MME : Speakers/Headphones (IDT High : Microphone/Line In (IDT High : 1 (Mono) Input Channel

What sample rate do you have set in:

  1. Audacity; “Edit > Preferences > Quality”
  2. The recording settings in the Windows Sound Control Panel

Audacity: 44100Hz (24bit)
Windows Sound: 44100Hz (2 channel, 24bit)

Try these settings with both Host = MME and Host = Direct Sound:

Audacity to 44100 / 32 bit (float)
Windows Sound: 44100Hz / 1 channel / 16bit

Not able to set Windows Sound to 1 channel.

All other settings changed. Will test and post back. Preliminary tests are looking good :smiley:

Tested on and off for around 4 hours now… seems to have worked! Thanks for your speedy replies!

Happy New Year! :mrgreen:

I have tried all of these things on the Wiki and what you just suggested and I am having the same problem. However, instead of shutting down mid-recording, it doesn’t even let me record. Really frustrated! I was recording with the mic and then all of a sudden I opened up a new Audacity window and it wouldn’t let me record with the mic anymore and kept giving me the error. Any help would be appreciated.

It is much better to start a new post rather than jump on someone else’s post. The other person probably has a different system to you.

See if this helps: FAQ:Errors - Error opening sound device .

If you need more help please state your version of Windows and your version of Audacity (all three numbers from Help > About Audacity… ). Give us the exact make and model number of the microphone.


Gale