Error opening sound device using Stereo Mix

I am working on an Acer Aspire using Windows 10 and had been able to use Audacity to record internal audio with Stereo Mix up until about a month ago. I am now getting the “Error while opening sound device. Please check the recording device settings and the project sample rate.” Both the Stereo Mix format and Audacity’s project sample are set to 2-channel, 16 bit, 48000 Hz (DVD Quality). I am successfully using Audacity with Stereo Mix on my Surface Pro. I am unable to change the sample rate/channels on either machine through the Control Panel, Sound, Recording, Stereo Mix, Advanced. Both computers have the same RealTek driver (6.01.7541 06/18/15) installed from the same executable, but the Stereo Mix drivers show different versions. On the Surface Pro it shows version 10.0.10240.16384 07/09/15, which works. On the Acer, the driver version for Stereo Mix is 10.0.10586.0 10/29/15 and does not work. Can anyone tell me how to get the appropriate Stereo Mix driver onto the Acer? What might be causing the format settings to be grayed out? I’m completely baffled why Stereo Mix was working on the Acer, then suddenly stopped working, while it continues to work on the Surface Pro. Thanks for any insight. Lisa

I don’t know why it quit working but with Windows 10 try [u]WASAPI Loopback[/u].

That is what I have been using, though I’ve tried every combination I can think of with MME, Windows Direct, and Windows WASAPI. Interestingly, Windows did an update last night and now my Audacity takes f…o…r…e…v…e…r to load. Will check into what this update was to determine why it’s affecting Audacity. It did not correct the problem…just made the error message take a long time to appear. :frowning:

Check on the Acer website to ensure that you have the latest drivers for your exact model of laptop and Windows 10 (32-bit or 64-bit depending on which version of Win 10 you have).

As Steve says, try the Acer site for the correct drivers for your computer model, but sometimes Windows can update those drivers and that can sometimes cause a problem.

If a bad driver keeps installing itself, see


Thanks everyone. I have the latest drivers from Acer (they only have drivers up to Windows 8.1 and they use Realtek sound) and as I mentioned, I have downloaded the latest Realtek driver (6.01.7541 06/18/15), but there a different version for Stereo Mix is listed on the Acer than the one on the Surface, despite the same RealTek driver being used. Very strange. Everything was working fine on the Acer until sometime in the past month. I was recording internal sound beginning of June and am just now trying to record again. I’m thinking it’s something with one of the Windows 10 updates. The option to “Never install driver software from Windows Update” shows as “Do you want to automatically download manufacturer’s apps and custom icons”. Maybe Microsoft removed this option? I’ll keep trying things and hopefully something will get it to work again.

You might want to take a look at and

Then you do not have proper Windows 10 drivers for your Realtek device and you may or may not get unpredictable behaviour or limited features.

Audacity taking a long time to launch could be indicative of an audio driver issue.

Have you considered going back to Windows 8.1?

You could try getting Windows WASAPI loopback recording going, rather than try to use stereo mix. The WASAPI lopback problem could be due to sample rate or Exclusive Mode choice.

Yes it appears so, but this option still seems to be available by editing the Registry or Local Group Policy (whether the setting works in preventing driver updates is now open to doubt again).

I updated