error opening sound device [SOLVED]

This desktop was running Windows 8.1 and Audacity 2.1.1would show error when I would click record. I now have installed Windows #10 and this same problem occurs. I have installed Audacity 2.1.1on my laptop with Windows #8.1 without a problem.

What are you recording? For example:

“I’m recording me playing the guitar into a Blue Yeti USB microphone.”

You can’t give us too much detail.

Koz

I want to record my voice and then guitar. Clicking the record immediately brings an error message as shown on my previous post. On my laptop it works as it should.

I want to record my voice and then guitar.

How are you doing that? In Detail. I’m singing into a what? I’m connecting my guitar how?

Koz

For some general help, see this FAQ: http://manual.audacityteam.org/o/man/faq_errors.html#sound_device.

As Koz says, we can’t help you in detail unless you give the make and model number of the recording device selected in Audacity and describe how the guitar and mic are connected to that device.


Gale

Snip for Audacit error.PNG.jpg
You are referring to steps after I click record, I can not get to those choices since I get the error imediately after I click recoord. Have you not viewed the screen shot (Snip) I sent with the first post? I will send it with this reply again.

As you can see, there was no screenshot in your first post.

As you can see in your now posted screenshot, you don’t have any enabled recording devices, hence Audacity cannot record.

So, quit Audacity, then open Windows Sound, Recording tab. Follow the steps in that Windows Sound link, starting with "Recording Settings: Right-click anywhere inside the Recording tab and choose “Show disabled devices” then right-click again and check “Show Disconnected Devices”.

If you need more help, PLEASE, give us the make and model number of the recording device you are trying to use and describe how the guitar and mic are connected to that device. If it is an external interface device, you may need to visit the web site of that device then download and install Windows 10 drivers for it.


Gale

I have not been able to communicate my problem to this point. You ask what and how I record and I don’t see that it matters when the record button brings me and error as shown on the several screen shots I have sent. You haave asked for the Audacity that I am using, so I now have also sent a screen shot of that.
Snipping Tool==Audacity==12-09015.PNG
Snip for Audacit error.PNG.jpg

When you press Record, Audacity tries to connect to your microphone. If it can’t find one, it flashes that message. We need all the information you have on that microphone.

Koz

The screenshot shows us that you have no recording devices enabled in Windows.

If you wish to solve that, please do everything I suggested in this post: error opening sound device [SOLVED] - #7 by Gale_Andrews

If you do not follow those steps, then you will continue to see the same error in Audacity and will not be able to record in any other software either.


Gale

Koz,

We are making slow progress. You want information on microphones. How do I get that?
My external microphones are working. I clicked the Audacity icon microphone and “Stop Monitoring” and “Preferences” show but activating these does not eliminate the error. I have installed Audacity several times on this Desktop and on two different laptops and this is the first time I have had this problem.
Koz, I hope you can continue to help and I “Thank you”

My external microphones are working.

Maybe not if the system can’t see them. Is that what you’re trying to record from? One poster only had a model number—no name—on the side of the microphone and we traced it back from that.

The microphone in this picture is a GLS ES-58 and it says so on the side of the microphone.




Gale posted steps to resolve the connection problem.

Koz

Exactly, they are not working on your current computer and will never do so if Windows does not recognise them. That is why you need to enable those mics by following error opening sound device [SOLVED] - #7 by Gale_Andrews

If you are saying the mics are recording on that computer using some other recording software, then at the top of Audacity, click Transport then “Rescan Audio Devices” and the recording devices will show up in Audacity.

It isn’t just the make and model number of the microphones that is important. It also matters where you are connecting them to on the computer, because where you are connecting them determines what device they are named as on Windows. But if you follow error opening sound device [SOLVED] - #7 by Gale_Andrews then the devices should appear and you may not need to describe them to us.


Gale

I have to suspend my problem for now. I think my Monitor has failed. You have given me many directions I will need to try when I get my new Monitor.

Thank You

Gale & Koz,

I now have my monitor working again, and so we can resume searching for a solution. The link Gale sent had my hopes up but the webpage was unavailable.
I have checked my speakers for idnentificaction and the barcode is all I see.
I have sent you a Snip of the Device Manager showing some identification of the speakers.
These speakers allow me to listen to audio on this Desktop and also from flashdrives.


I was not able to find the links you directed me to. In “Control Panel” I used “ Hardware& Sound”. I then used ‘Manage Audio Devices” which got me to the ‘Sound Page” with the “ Recording Tab” I right clicked the “Speakers icon” and Used “Test” which gave me the dings for audio. I then used “Configure” which also gave me audio. I left “Disabled Devices’ and “ Disconnected devices” boxes unchecked. I did update drivers where it seemed logical.

Let me know if there are other ways to make this easier.

If you leave “Show Disabled Devices” and “Show Disconnected devices” unchecked, you’ll never know which devices are disabled or disconnected for Windows. Try checking both options. Your mic might show up as a disabled or disconnected device, in which case you should right-click on the mic button and choose “Activate” from the menu.

Just to note, in English locales, it will say “Enable”.

Gale

Here is a direct link you could read: Missing features - Audacity Support.

We are not interested in your speakers, because we know your speakers are enabled in Windows. The Speakers will be on the “Playback” tab. Go back to the “Recording” tab and do as Robert says - right-click in empty space and choose “Show Disabled Devices”. Right-click again and choose “Show Disconnected Devices”. Right-click over each device that appears and choose “Enable”.



Gale

I did what you directed but it did not help. I am working several times with the Recording tab, both connecting and disconnecting and it shows enable but also shows “not plugged in" The red arrows seem to mean it is enabled
I am able to play music from the Desktop and also from the flashdrive.
I am sending you a new snip
Snip for Audacit e.PNG=12-15.PNG.jpg

Is your mic actually plugged into the pink port at the back of your PC? Is there an on/off switch on your mic?