error opening recording device error code: -9999 sonic port vx

Hello all,
I’m using Windows10, the latest version of Audacity 2.3.3 and have the Line 6 Sonic Port VX device connected to my computer.
I’m getting that well-known error message: Error opening recording device. Error code:-9999 Unanticipated host error.

The fancy thing is: I could record the very first time I plugged in the device, then I deleted the recording and tried to start again to record, the result was the error message mentioned. I went to Windows setting trying the Microphone troubleshooting and funny enough, it resolved an issue of different setting (in Window and Audacity I presume, probably bitrate-settings), but i couldn’t repeat that in further attempts.

I’m very new to all that recording stuff, but I tried some of the advices given already here and elsewhere without success:

  • Audacity app is allowed to use the microphone
  • closing Audacity and reopening
  • opening Audacity with administrator permissions
  • restarting the PC
  • Transport - Rescan Audio Devices
  • reinstalling the driver
  • there was a post where anti-virus software was the culprit, but I couldn’t find respective settings in my anti-virus software
  • I noticed that in the two attempts anything was recorded, I tried to switch between the Sonic post microphone and the guitar input, this switch did not seem to work, not sure it this is recognized by Audacity

My settings are Windows Direct (in the first successful recording attempt), resp. MME / Recording Device - Digital Audio Interface Line 6 / 1 (Mono) / speaker Realtek / Project Rate 44100 Hz (this should be the same as in Windows settings).
Sonic port VX is recognized as I could record already. But why can’t I resume recording a second time and what could be the reason that the switch between Sonic port mic and guitar input does not work. Any known issues or perhaps I only am not familiar with the Audacity buttons?

I would appreciate any suggestions as to get it work on this PC as I will have to install this again on an old Windows 7 laptop.
Thanks a lot

That should never be recommended. Administrative permissions should only ever be used when you need to make changes to the system. It is potentially dangerous to run ordinary applications with administrator permissions.

Unfortunately this is not a very helpful error message - it just means “something is wrong”, but the cause is not identified.

The useful part is that the message identifies the “recording” device.

Look in the Windows Sound settings, in the recording tab, and see if the green meter to the right of the device that you are using is responding to sounds entering the device.

Hello Steve
thanks for replying.
I do not intend to open Audacity continually with Administrator privileges, was only for testing purpose.
I went to Windows Settings - Sound
What happens if I plugin my Sonic Port VX into my USB port, it will be recognized as default speaker. Plugging in headphones in my Sonic port, I can hear e.g. my Media player.
In the settings itself, switching to Sonic port VX microphone, I can see the meter deflecting, when I talk into the mic, showing that it is recognized.
Switching to the guitar input, I can see the meter deflecting, too, but only to a very minor level. There is no gain for this input, only for the mic’s one. But I suppose that gain of guitar input can be amplified by Audacity.
Anyway, Windows will recognize my device in both modes.

And as already said, Audacity got permissions to microphone access.

Best regards

Using Audacity 2.3.3 on Windows 10 with Line6 Sonic Port VX recording device

If you shut down Audacity, then relaunch Audacity, can you record one track from the Line 6 Sonic Port VX?

Have you installed the version 1.91 drivers for Windows 10?

Hello Steve
I had another try and had a closer look to Audacity manual in order to be sure not to commit a beginner’s fault.
The result:
Starting Audacity after the first computer start: I could record guitar and I could switch to the mic. Both recordings were joined in one track.
Then I stopped that track, played it and tried to add another recording - the said error message appeared. As well trying to record to a new track by using Shift failed.
Closing Audacity and trying to record again won’t do the trick - no recording is possible and the error message remains the same.
And yes, I downloaded the latest driver (Line 6 Driver2 SonicPortVX v1.91 Installer.exe) and followed instructions only inputting the USB-cable after being requested by the installation software. I had a look to Windows device manager, and the Line6 driver V1.91 is recorded there.
So Audacity is able to recognize the Sonic Port VX, but apparently only once.
BR, Andreas

I am having a similar issue. I am on a window 10 with a Behringer UM2 it has worked. I can record no problem the first track but cannot record a second track with my audio speakers on the Behringer it will only let me record if the speaker is set to ISST internal speaks. (When I try with the Behringer driver setting I get error code 9999). This does not help me as I need direct monitoring so I can time my records. Please Help. I have tried allowing access to the microphone in the privacy settings but it didn’t work. I right clicked on the speak icon next to the clock and made the Behringer the default mic. I have restarted my computer. Nothing is work and it is really holding things up.



Look in the Windows Sound settings and ensure that the Behringer is set to use the same sample rate (example: 44100Hz), bit format (Example: 16-bit), in both the recording devices tab, and the playback devices tab.