Error opening recording device. Error code: -9996 Invalid Device

I’ve been using audacity for years, and it’s been great up until recently. I am running a Windows 10 PC with a Corsair Virtuoso wireless USB headset for audio. I am trying to record desktop audio (what I’m hearing) instead of the headset mic. When I press record I get the error message in the title.

The headset is brand new. It plays audio great. The microphone works great. Since I’m recording the WASAPI stream, it’s not really the device that is being recorded. I tried my old headset (also wireless USB) and had the same results. When I run OBS to make videos, it is able to record desktop audio into the video.

My audio settings are as follows:
Host: Windows WASAPI
Playback: Headset Earphone (Corsair Virtuoso…)
Recroding: Headset Earphone (Corsair Virtuoso…)
Channels: 2
Sample Rate: 48000 Hz (haven’t touched this setting)
Default Sample Rate: 48000 Hz (haven’t touched this setting)
Default Sample Format: 32-bit float (haven’t touched this setting)
Buffer Length: 100
Latency compensation -130

This topic was automatically closed after 30 days. New replies are no longer allowed.