Error opening project

Hi,
i recorded my set of yesterdays party and they turned the power off before i could save it. Now, Audacity is asking me if i want to restore the project —>yes i want —> Error: not well-formed (invalid token) in line 24927

i pressed “ok” and saved the project anyways (–< i got the file 174.aup and the folder 174_data, containing 8.22GB) and tryed to open it again in different ways but the same error appears and still Audacity ask for recovery of the project every time i start it. I read the faq and tryed google but i still dont know what to do. no strange characters, not even the line 24927 exists?!

Would be very nice if u can help me. It was an awesome party and i would enjoy to have the set for eternity :wink:

btw: Audacity 2.0.0 on Win7 64-bit, i uploaded the 174.aup also.

Thanks & greetings!

-Impus-
174.aup (406 Bytes)

I think the chances of getting the show back with that much damage are zero. 8GB? How long was the show?

We can wait for the other elves.

Koz

About 7,5 hours overall. That wasnt only my set but the sets of some of my friends also.
But it was splitted on a 2. sound tracks after approximately 3 hours, stopped by a technical issue and I continued recording at the same project.

Its wasnt the first time that i was recording a whole evening with the end that a technician was shutting down the power before i could save the whole project. recovery worked fine every time until now.

Were you recording at a high sample rate? If so, you may have exceeded the maximum size limit for saved Audacity projects: Missing features - Audacity Support

no, sample rate is at 44,1 kHz

If you got “error not well formed” after trying to recover the project, I don’t really understand how you saved other than an empty _data folder unless you renamed the temp folder to “174_data”. Didn’t you see and save an empty project after receiving that error?

When you fail to open a recovered project as here because the project cannot be read, Audacity will continue to offer to recover it whenever you launch the program. It will do this because it still has an autosave file (temporary project file) at C:UsersAppDataRoamingAudacityAutoSave.

What happens when you recover that project - the same error at line 24927?

If so then you need to fix the autosave file at that line. I suggest you make a copy of the autosave file and move the copy to your desktop for safe keeping. Please attach the original autosave file. You may need to show hidden files and folders in order to see the AppData folder.


Gale

Yeah, i only see an empty project after opening and getting the same error again and again, doesnt change anything if i recover or open the saved “empty” 8.2GB project. It seems like audacity cannot read his own data any more but saved it anyways in hope that the elves can fix it :confused:

Here u are. I didnt see the line number in wordpad etc. and my manual search failed…
https://www.dropbox.com/s/a28jlprplifs2p5/Neues%20Projekt%20-%202013-05-26%2000-53-55%20N-6.autosave

The line 24927 is there but mostly null characters. I think the autosave file may be corrupted by the loss of power. You can try the attached which I have edited, but you may only get the first half of the audio where the autosave file looks normal. If opening that file gives an error, please tell us the exact error message.

If 7.5 hours was the total length that is within the limit, but two recordings of 7.5 hours in different tracks in the same project would be over the limit (at 44100 Hz project rate).


Gale
Neues Projekt - 2013-05-26 00-53-55 N-6.autosave (1.33 MB)

Its max. 7.5 hours total length =)

After opening the modified file “Neues Projekt[…].autosave” audacity asked me for recovering the old project. I tryed “yes” and the old error in line 24927 appeared, so I opened it again and droped the recovery. After ~5minutes of loading then, another error appeared: “Warning: Problems in Automatic recovery. Project found file inconsistencies during automatic recovery. Select “Show Log…” in the Help menu to see details.”

How did u find the line 24927 (I suppose u didnt count^^) and what changes did u do there?

I attached the log-file here. Dropbox - Error - Simplify your life
It seems that it doesnt find the right data. So I checked the e00-flolder in the temporary folder and it contains only 4.2 GB. I decided to save this data into another backup folder and I overwrite it with the e00-folder with 8.2 GB.

AND HERE WE ARE !!! The data is sucessfully restored! I exported the different tracks and now I am the proud owner of the recording in 2 parts, one 136:09 minutes and one 265:30 minutes, perfect! :mrgreen:

Thank you very much, Gale! Awesome work. :slight_smile:

How can i thank u?
Maybe u will like this:

Wohnzimmer = living room, its a Drum’n’Bass set which I recorded to chill out, u won’t hear most of the tracks in clubs nor in public radio shows. I hope u enjoy!

Best regards!
-Impus-

I use “Go to” in a text editor like Notepad++ ( http://notepad-plus-plus.org/ ) .

I “fixed” the autosave file by removing the offending line cited in the error, as described here Help me to save my project: Error: not well-formed - #7 by Gale_Andrews .

Thanks for working it out for yourself. I was never sure what exactly you did, but I am guessing you moved the 8.2 GB of temporary data into the “174” project. Therefore to recover from the autosave file whose “datadir” in line 3 was pointing to “C:UsersDELECR~1AppDataLocalTempaudacity_tempproject7675” , you had to move the data back there.



Gale