Error: mismatched tag at line 154

I have just installed what I presume is the latest version of Audacity by putting the instruction - sudo apt-get install audacity in the Lubuntu terminal.
The programme seems to open OK, but when I try to open my files recorded with a previous version of audacity, maybe 3 or 4 years old, I get a window saying “Error: mismatched tag at line 154” … is there any way to fix this? Perhaps I need to download some more software to ensure compatibility? How can I do this (I’m not a dab hand at Linux instructions just yet!)
Thanks to anyone out there who’s listening!

That indicates that there is an error in the AUP file.

If you attach the AUP file to your reply, we can take a look and see if it is repairable.
See here for how to attach files to forum posts: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

Thanks Steve for your timely reply… but I’m pretty sure the aup files I tried to open is OK… since they play fine on the previous version of audacity (2.1.0) installed on my other pc (with windows 7)… I copied them onto a pen-drive together with their data folders.
The problem seems to be that the file was created with that previous version of audacity and now seems to be incompatible with whichever version I have installed on linux (lubuntu 14)
I installed it via the terminal with the sudo command “install audacity” so presumably it’s the latest version, but when I go to /home/usr/.local/share/applications where it was installed and try to get the file properties it just says “desktop configuration file” without telling me the version number… in addition no files or folders or app extensions appear to be installed in association with the application… even if I show the hidden files… it’s all a mystery to me where they are!
I also downloaded the manual today and put it in the .local/share/applications folder, but audacity doesn’t seem to recognize it and I have to go online to read the manual.
Any useful suggestions?
Thanks again!

The current version of Audacity is backward compatible with previous versions of Audacity. In other words, old projects may be opened with newer versions of Audacity.

Did you build Audacity from the source code first?
The “sudo install” command copies files (often just compiled) into destination locations. If you want to download and install a ready-to-use package on a GNU/Linux system, you should instead be using a package manager such as Apt, Synaptic or the Ubuntu Software Centre.

If you have Audacity installed, the way to get the version number is to launch the application, then look in “Help menu > About Audacity”.

The error message “mismatched tag at line 154” indicates that there is an error in the AUP file at line number 154.

Looking back to your first post, you said:
“by putting the instruction - sudo apt-get install audacity in the Lubuntu terminal.”
I assume that your original post is correct rather than the later post.
Please try to be accurate and precise so as to avoid confusion.

If you have an older version of Lubuntu and used apt-get you will not have a recent version of Audacity. What do you see in About Audacity?

We can’t help with the mismatched tag unless you attach the AUP file. There is no reason it would open in 2.1.0 but not in a later 2.1.x, unless there was some encoding problem when you transferred it between different operating systems.

Gale

Thanks steve and gale for your posts… I have tried reinstalling audacity via the Ubuntu software updater prompt which always opens when I turn on the pc but still get the message “Error: mismatched tag at line 154”
When I said “I installed it via the terminal with the sudo command “install audacity”” yes, I of course meant “by putting the instruction - sudo apt-get install audacity in the Lubuntu terminal”… I just wanted to save a few words!
I checked the version number with your method… it’s 2.1.2
I don’t think i “built Audacity from the source code first”… in fact I have no idea what that means in practice… nor do I really know what a “package manager such as Apt, Synaptic or the Ubuntu Software Centre” is… or how to get one… I would assume they (or one of them) are already installed on my Lubuntu/Ubuntu 14.04.2 LTS operating system… otherwise I presumably wouldn’t have been able to dowload audacity in the first place…
I had originally downloaded audacity as a zipped file from the website, but when I utterly failed to install it or get it to run I opted for the “sudo apt-get install audacity in the Lubuntu terminal” method, which always seems to work once you know the right words for the task, and it at least got the programme installed and running.
The fact is that the message Error: mismatched tag at line 154 appears no matter what aup file I use from the previous version of audacity… so I guess the problem is not due to the file itself but due to the compatibility of the programme …
I simply copied them onto a pendrive… there have never been compatibility problems with any other files I transferred from windows 7 programmes in that way.
Anyway I’ll try to send you a aup file from the previous audacity version from my other pc in a day or 2

This doesn’t make complete sense to me. The repository version of Audacity for Ubuntu 14.04 is 2.0.5. Your reply suggests you enabled other software sources in the software updater and actually have the alpha daily development build of Audacity installed as a PPA package - this one: https://launchpad.net/~audacity-team/+archive/ubuntu/daily. If so you should be aware those builds are unstable builds for testers and not intended for the average user who just wants a reliable version of Audacity.

I would have expected those PPA builds to show 2.1.3-alpha in About Audacity but I am not sure about that.

Your description that you used to have 2.1.0 and now have 2.1.2 actually suggests you have this PPA:
https://launchpad.net/~ubuntuhandbook1/+archive/ubuntu/audacity

which is a stable release for end users. But to install that you would have needed a different command

sudo add-apt-repository ppa:ubuntuhandbook1/audacity
sudo apt-get update



This isn’t a known problem with compatibility between Audacity versions, so when you can, please attach an example AUP file that shows the problem.


Gale