error message

Windows 10

For starters I don’t know what this refers to - the exact three-section version of Audacity from Help > About Audacity (( do you mean 2.1.0?)) and whether you obtained the .exe installer or the zip.

I got the following message when opening your program:

Error when opening sound device. Please check the recording device settings and the project sample rate.

That means absolutely nothing to me. I have no idea what you expect me to do. It would be helpful if you included detailed instructions so customers with limited experience with your program would be able to trouble shoot the problem!

Audacity is issued with three numbers. I’m using 2.1.2 right now. Lots of programs don’t do that and people assume they can abbreviate the number when they post for help or just leave numbers off. Bad idea. Also, There are bogus versions of Audacity that have scrambled version numbers. If you are using 2.12 and it’s real, there’s a terrific possibility you have fake software.

Only when you give us the real number are we starting from a level field.

Depending on which download you got, you have help and instructions with your download. They don’t all have that and it’s good to know.

That means absolutely nothing to me.

The English version of that is “We can’t figure out how to run your computer sound equipment. Give us a hint.”

Macs tend to have a limited number of sound systems, but Windows can have millions of different ones and it’s actually worse than that because you can have a normal sound system that stopped working because you upgraded to Windows 10. Audacity will try to connect with some plain, general settings, but if it fails, you get that message. That’s our version of “Check Engine” in your car. That could mean your windshield wipers are wearing out.

So what are you recording or why are you using Audacity? The more details the better. For example: “I’m trying to record an audiobook with a Blue Snowball microphone.” Right away I know you’re using the USB system and I can Google the microphone.


Meantime here is the FAQ about the error - please see if it helps:

If you are using a USB device it could be as simple that you pulled the USB cable out by accident. Reconnect the cable, and if necessary, use Transport > Rescan Audio Devices in the Audacity Menu Bar.


When attempting to start a new recording I get the following message:

Error while opening sound device. Please check the recording device settings and the project sample rate.

I have absolutely no idea what that means or where to start to fix this error. If anyone knows please lend a hand but make your instructions simple. I don’t have any experience in this area. I sent an email to Audacity about this problem but I’m not getting a response.

P.S. I’m using Windows 10 and audacity 2.1.0

It means that there is probably something wrong with your recording settings.

What are you trying to record?
What equipment are you using?

There is no technical support by e-mail. Audacity Forum is the place to ask.

2.1.0 is not the current version of Audacity. You can obtain the current 2.1.2 version of Audacity from

Are you also seeing “No audio devices found. Internal PortAudio Error” when you launch Audacity? In that case please read this help section carefully:

Otherwise this FAQ has help with the “Error opening”:

If you still need help after that, please answer Steve’s questions in full detail.


I merged your two topics. Please do not double post the same question. Reply in this topic if you need more help.


Double Posting? What “TWO” posts are you referring to? I only made the one post.

I’m recording music from a web site that is played through my computer straight into the Audacity program. So the only equipment that is involved is my computer. This has worked perfectly for quite a while. Then all of a sudden the error started popping up. The only thing that I can think of that may have caused this problem is that the Windows 10 program did an automatic update. It’s the only change to my computer that took place between things working properly and the error message popping up. My electronics instructor had an explanation for all electronic problems “VooDoo Electronics”.

All of the help is appreciated!!

I uninstalled Audacity 2.1.0 and installed 2.1.2 and “No Joy”!

If you’re trying to record the sound playing on the computer, try selecting “WASAPI” in Audacity Preferences, “Devices” …
WASAPI selected in preferences.png

You posted the content of as a new topic which is essentially a repeat of your original question in this topic

Make sure you are subscribed to this topic (see the link bottom left) then you will be e-mailed when there is a reply.


Thanks Trebor!
Before reading your post I tried using Audicity one more time and it was working perfectly as it was in the past. Didn’t change anything but now it’s appears to be working just fine. I checked the “preferences/devices” as you suggested. Mine was set as “MME”. What’s the difference between the two (MME and WASAPI)?

They are different audio API’s (different protocols for accessing the sound device). Have a look at and the links in blue on that page.