error message when trying to record from cassette

I have audacity 2.1.2 that I downloaded as dmg not as zip.
I have MacBook Pro 2010 and OS X El Capitan.
I have Soundflower 2.OB2.dmg , which I read on the internet is necessary to use Audacity. There doesn’t seem to be a way I can open it, just downloaded it. It isn’t listed in my applications list in Finder. Perhaps it is not something that I need to open?

I have EXCap USB Audio Capture (the cables, not the cassette player). I am using Sony Walkman as the cassette recorder.

I am able to get to the screen which shows Core Audio, USB PnP Audio Device, Stereo, Built In Output.
When I click on record it get the error message “Error while opening sound device.Please check the recording device settings and the project sample rate,”
That stumps me. I don’t know how to check those items.

4 screenshots below
Can you help?
Screenshot 2016-09-23 09.06.50.png
Screenshot 2016-09-23 09.04.21.png
Screenshot 2016-09-23 09.02.01.png
Screenshot 2016-09-23 09.03.09.png

Soundflower is only needed when you want to run Play and Record on the same show at the same time, for example, recording a YouTube show. You don’t have to install that to record a tape.

I need to post back when I can get to a larger computer. Someone else may jump in.


recording device settings and the project sample rate,

Those settings are in Audacity > Preferences > Quality and Audacity > Preferences > Devices.

Good first-pass settings are 44100, 16-bit, Stereo.

Also see:

It’s also good to know Audacity checks for devices when it starts. So if you start Audacity first and then plug in your device, it will be invisible. You can also Transport > Rescan…


I assume you mean EZCap. If it says it is a video capture device, it probably won’t work with Audacity because Audacity expects a pure audio signal that isn’t wrapped in a non-existent video signal.

If this matches with what you bought then I assume if should record in Audacity if the device is not defective. You may need to go to /Applications/Utilities/Audio MIDI Setup first - select it there as input device and set it to 44100.0 Hz 2-ch. Restart Audacity.

Does it record in GarageBand?