Error in lauching Audacity

I compiled Audacity using VC2013 express. Overall, I used the instructions I found on the Web. Please see attachment. The compilation was successful with a few warnings. I then went to the Audacity/win/audacity.exe to launch the application and I got the error message. Please see attachment. Probably, the instructions I followed are outdated. Please help.

I have another question. Should the Widget be also compiled with VC2013 Express? I compiled the Widget with VC2008. Could this be the problem?
Compiling Audacity.txt (19.5 KB)
Error Message.png

wxWidgets must be compiled with the same version of Microsoft Visual Studio as you used to compile Audacity. BTW, about a week ago Microsoft decided to make Visual Studio Professional available for free to everyone - you should uninstall 2013 express and install the Professional version (Microsoft Visual Studio 2013 Community).

After compiling wxWidgets with MS VS 2013 make sure you copy all of the appropriate wxWidgets libraries into the appropriate build folders for Audacity. Make sure you are building wxWidgets 2.8.12 for the Audacity Debug & Release configurations (there are also two highly experimental configurations for testing wxWidgets 3 - wx3-Debug & wx3-Release; for those you would need to build wxWidgets 3.x with MS VS 2013).

Thanks Edgar for replying this posting.

I have some comments and questions again.
It appears that the Visual Studio 2013 community edition has bugs. During compilation, it stopped working from time to time. I have installed all the updates that are available. As a result of the bugs, I had to start the compilation again and again to get it finished.

I have to admit that I am not an expert in compiling Audacity. I got hold of a very detailed instruction to compile Audacity and it worked in the past (see the attachment). Essentially, I need to copy the setup.h file from Audacity of wxWidgets 2.8.12 to use the accessibility features t and compile the wxWidgets using VS 2008, Batch build everything except those associated with “Universal”. I need to “convert” before compilation. This is it for wxWidgets. Of course, I have to set the correct path/environmental variable. Is it the same if I use VS 2013?

Audacity is on D:\Audacity. When I compile Audacity using the old instruction, I need to set up a directory on D drive, named wxlib with two subdirectories, Unicode Release and Unicode Debug. I copy the correct/necessary .dll files from wxWidgets/lib/ vc_lib and place them in the corresponding subdirectories. I also copy the two subdirectories into Audacity/win. At this point, I can go ahead and compile Audacity by double-clicking the .sln file. Of course, I need to choose either Release or Debug. After compilation, a new file called Release in the Audacity/win/ is generated. In this new directory, the audacity.exe now exists. This is it. Last time, when I tried it, I did not get the .exe file. Is it the same way when I use VS 2013? I know there is text file in Audacity to show how to do compilation using VS 2013, but does not show where to put those .dll files or I do not understand where to put them. Can you show me where to put them using the drive letter D with all the directories, e.g., in D:\Audacitybuildmxw…

Thanks for your help.

I really doubt that you are running into bugs in VS 2013 Community. I have been using it many hours a day since the day it became available for free and have not experienced any bugs.

Nothing attached that I see. There’s a fairly good chance that I am the author of the “very detailed instruction” if so, you are right those instructions are a little out of date especially concerning VS 2013. After the next release of Audacity (2.1, probably late January) the Audacity Developers will probably switch to wxWidgets 3; at that time I will probably revisit my “detailed instructions” and bring them up-to-date. My instructions are here:

It is the same with VS 2013. After converting the wxWidgets solution and compiling all of the libraries you will still need to find the 10 that you need and copy them into the appropriate folders.

Those instructions are essentially the same but the target folder names were changed: in the Audacity folder “Unicode Debug” is now simply “Debug” and “Unicode Release” is “Release”, the wxWidgets names remain the same.

Correct, there is now a file Audacity.exe in the folder Audacity/win/Release and there should be all five of those wxWidgets libraries that you copied earlier.


The above shows the folder structure you should have; inside D:\AudacityRelease you should have the application “Audacity.exe”, 5 DLLs, and some folders (plug-ins, nyquist etc. - exactly which folders will be there will be dependent on if you built the locale solution).
Good luck, post back here with your success.

Hello Edgar:

I have run into a big problem. I did exactly what you told me to do according to your reply. Briefly, I compiled wxWidgets first after copying the setup.h and window.cpp into the corresponding locations. The window.cpp file is new, but I found the instruction to place it where it is supposed to go. I converted the files and compiled according to your instructions. After the end, I got the message “168 succeeded, 20 failed.” I did not expect a 100% success rate. I went ahead to compile Audacity according your instructions. This time, I created the D:// wxLibs/Release and D://wxLibs/Debug since I had D://Audacity. I copied all the necessary .dll files into the corresponding directories from the newly compiled wxWidgets. I also copied the two subdirectories into D://Audacity/win. Then I compiled the whole solution with everything checked in the configuration Manager of VS 2013 except anything containing the name Universal. I changed the default Debug to Release before compiling. I got a final message " 25 succeeded, 1 failed". I attached the both the Build-output text files for you to review. After the compilation was completed, I went to open up the D://Audacity/win/Release. It appeared a lot of files were missing compared to the previous Audacity versions compiled with VS2008 and there was no Audacity.exe. I am snowed. I have also attached the screen shot of the D://Audacity/win/Release to show you the content to give you an idea of what is missing. Thank you for your help in advance.
Compilation Errors of wxWidgers 2-8-12.txt (384 KB)
Output-Build for Audacity 2-0-6.txt (128 KB)

I think you are really close. It looks like you have a corrupt download. When you are trying to build the Audacity project you get this error:

......srcLyrics.cpp(99): error C2039: 'SetHiohlightFont' : is not a member of 'Lyrics'
          d:audacitysrcLyrics.h(59) : see declaration of 'Lyrics'

SetHiohlightFont is a misspelling/typo (line number 99 of file srclyrics.h). I have no idea how it happened but it should be:


FYI, you do not need all of those files: *.lib in the Release nor Debug folders. They are actually picked up via the WXWIN environmental variable. It does not hurt anything to have them there. You have the proper wxWidgets DLLs. You do not need to worry about getting wxWidgets to compile any further. Keep me posted!

Hi Edgar:

Thank you for replying. Are you suggesting me to go into the code and change the spelling or it is better off to download it again. Is it possible the misspelling is actually in the code to begin with and not caused downloading?

Please advise.

Actually, I would suggest both. Download errors are not impossible but, after over five years of downloading and re-compiling the Audacity source code almost every day, I have only had a couple of bad downloads. First, go into the code and change the spelling of that word. Recompile and see if that resolves all of your compile issues. If Audacity compiles and runs it might be safer to download again and go through the whole process again.

I don’t think you have ever told us why you are trying to compile Audacity. If you are a programmer and want to make changes yourself, if you just want to try out the very newest beta code or, if you want to compile it for ASIO - whatever, please be aware that the Audacity Team Developers are planning on releasing a new version of Audacity in mid-January or thereabouts. You will certainly want to download that new source code when it’s released and go through this whole process once again because there are some exciting new features and a lot of bug fixes.

Hi Edgar:

I compile Audacity because I want to use ASIO.

I obtained Audacity again via the SVN. Before I did anything I opened up …src/lyrics.cpp to make sure there was no typo and there was no typo. However, it still did not work. I got the same thing in the Release directory. I am attaching two files for you to review.

Error Message from VS2103 12-7-14.txt (230 Bytes)
Output-Build 12-7-14.txt (128 KB)

I thought you were trying to compile the 2.0.6 code. Today, and maybe for the last few days, SVN HEAD is broken and will/may not compile. What you need to do is get the 13358 (2.0.6) revision via SVN:
Then in late January, after 2.1 is released, use SVN to checkout that code and recompile - the Audacity Team Developers have implemented a lot of new features and there are still some bugs to work out.

Hi Edgar:

It is getting worse when I use the version you suggested. As usual, I created the two Release and Debug files and placed them in the proper place. I then double clicked the audacity.sln. Of course I needed to migrate or update the files for VS 2013. Immediately after migration, I found the Audacity directory had a red dot instead of green. The red dot also appeared in the win directory and the subdirectory Project. I went ahead and compiled Audacity. It did not work at all. I had no audacity.exe in the Release directory. Now I got 20 directories compiled successfully with 6 failed. It is worse than before. I also attach the build-output for you to review. Is it because of the VS 2013 or something is wrong with the code? Should I wait until after January next year? It is very frustrating.

Thank you in advance for your insight.
Output-Build for vesion 13__.txt (520 KB)

My apologies, 2.0.6 must be compiled with Visual Studio 2008 (you may have both VS 2008 & VS 2013 installed at the same time but, if you do and you want to use 2008, you must use “Open With” from the context menu (right click on the SLN icon).

As for waiting, you will need to decide that for yourself. I would strongly suggest not trying to use the current SVN HEAD for production work - it is still very much a work-in-progress and is undergoing comprehensive beta testing and bug fixing right now. If you need production code for the next 6 to 8 weeks you’ll need to install VS 2008 and compile 2.0.6. However, there are some great new features in 2.1 and a lot of annoying bugs have been fixed - it must be compiled with VS 2013; I strongly suggest that you plan on updating to 2.1 as soon as practical.

Hi Edgar:

I have no choice but to wait. I have de-installed VS 2008 from my computer and it is too much trouble to re-install it. When it January or February come, I will talk to you more. If you have more info, please send me a note.

Many thanks.

Hello Everybody:
I am back. I got 2.1.0 successfully compiled for ASIO. I have been able to record and play. Now I am trying to make an installer by using the Inno setup compiler. After I opened up the .iss file, I know I had to change the code a bit to indicate the location of the Visual Studio. I un-commented Line 118 because the default drive letter is C and I changed it to D. Insert the word “source:” in front of the line and deleted the word “or”. I then save/build/compile. Now I got an error message saying the DesDir was not indicated. I added this code ; DestDir: “{app}”; Flags: ignoreversion to Source: “D:Program FilesMicrosoft Visual Studio 12.0VCredistx86Microsoft.VC120.CRT”. Then save/build/compile. Now I got an error message saying that the Microsoft file …vc120.crt does not exist. But it is there. I am snowed. Would anybody shed some light on this problem.


I should also ask if there is anything else I need to know for making an installer.


As I understand it you have now solved the INNO issues as per


Is your post related to this topic in some way?