Error Importing

Hey i recorded a very fire track buut in the name of my beat was a symbol so when i tried to load it it showed me : Error Opening Project: Reference to invalid character number at line x — So i read the manual but opened my audacity file in Windows Wordpad- I probably erased what i needed , but when i tried to load it it showed me : Error Importing: aup is an Audacity Project file. Use the File > Open command — Then i noticed that opening it in a Wordpad was a mistake so i downloaded Notepad++ which is recommended and i tried to repair it anyhow. Sadly, i couldn´t find any solution as my file is still damaged and i can´t open it. I don´t have any Backup. Please help me, what should i do now ? Where the problem could be ? Thank you if you´ll find some time to help me :slight_smile: :bulb: :bulb:

Please post the .AUP file and we see if it looks repairable.
See here for how to attach files to a forum post: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

alright, there it is
A Man (Travis Scott x Lil Pump x Scarlxrd Type Beat) _by BLACK LIONS BEATZ _ TYPE BEAT, BEATS, 2018 FREE DL [soundtake.net].aup (56.4 KB)

  1. Create a new folder somewhere convenient (for example, on the Desktop), and name it “myproject” (without quotes).

  2. Copy the folder “A Man (Travis Scott x Lil Pump x Scarlxrd Type Beat) _by BLACK LIONS BEATZ _ TYPE BEAT, BEATS, 2018 FREE DL [soundtake.net]_data” into the folder “myproject”.

  3. Rename the copy of “A Man (Travis Scott x Lil Pump x Scarlxrd Type Beat) _by BLACK LIONS BEATZ _ TYPE BEAT, BEATS, 2018 FREE DL [soundtake.net]_data” to “A_Man_data”.

  4. Download this file into the “myproject” folder:
    A_Man.aup (56.1 KB)

  5. Launch Audacity 2.2.2 (if you don’t have version 2.2.2, you can get it here: https://www.audacityteam.org/download/)

  6. “File menu > Open”, and select the project file “A_Man.aup”

What happens?

It didn´t work :confused: Im still getting the same message… Well, is that lost forever or is there any other way ?

OK, try this version:
A_Man.aup (56.1 KB)

Oh, you did it . Thank you so much :wink: :smiley:

Excellent :smiley:

The problems were twofold:

  1. Older versions of Audacity do not handle extended character sets very well (improved in recent versions of Audacity)
  2. WordPad (and Microsoft NotePad) implement Unicode “the Microsoft way” (aka “incorrectly”), and automatically change the character encoding of the document.

Two things I would suggest:

  1. If you’ve not already done so, upgrade to Audacity 2.2.2 at your earliest convenience.
  2. Don’t use WordPad (or NotePad) to edit AUP files. Generally, you should not manually edit .AUP files at all, but if you have to, use NotePad++, which by default uses the character encoding of the original document.

Hello Steve,

I encountered the same problem. I have tried multiple times to open the file, but it comes up with the same dialogue box the OP got. I have gone ahead and followed all the steps you listed, but am unable to go forward because there is no file here to download. I know it is a lot to ask, but would you be able to help me out in the same way you helped out the OP?

I have renamed the file I copied into the “myproject” folder “Ghost_data”.

I can attach the aup file here.

Afterward, I intend on upgrading to the latest version of audacity to avoid this problem in the future. For the time being, would you be abel to help me out?

Thank you in advance,

Jimmy
Ghost Pokemon Video Commentary.aup (75.3 KB)

What line number did it say?

Also, I am using Windows 10 and Adacity 2.1.3 if this helps.

My apologies. It was poor reading on my part. It was not because of a character in the file name. I am attaching a screenshot of the dialogue box if that helps.
Error importing audacity.PNG

I ensure you that I have used File > Open every time I tried to open the project. This one really has me scratching my head.

On this forum it is generally best to start a new topic. It’s much better for people if there is just one problem being discussed at a time.

Unfortunately this file is totally corrupt. Looking at the file in a hex-editor, it is filled with zeros.

I’d highly recommend that you update to the current Audacity 2.3.2 at your earliest convenience. You can get it via the links on the Audacity website: Audacity ® | Download for Windows

Okay. Thank you for your help and speedy responses.

Hello there, Is there anything that can be done with this one? The file seemed fine a few days ago, not quite sure what’s happened.

It’d be greatly appreciated Steve if anything could. I’m sort of at my wits end :C

Many kind regards

Mr Joj
13 running on empty.aup (267 KB)

No, it is totally corrupted. Nothing can be salvaged from that file.