Error compiling CVS version

I’ve been trying to compile Audacity from source (so that I can try out the latest CVS version):
I was following these instructions: http://audacityteam.org/wiki/index.php?title=Developing_On_Linux

After installing WxWidgets and some other stuff that it said was reuired, “./configure” completed without any errors, but “make” fails with the following errors:

make[5]: Entering directory `/home/steve/audacity/lib-src/redland/raptor/src'
yacc -b parsedate -p raptor_parsedate_ -d -v ./parsedate.y
yacc: e - line 167 of "./parsedate.y", syntax error
%pure_parser
^
make[5]: *** [parsedate.c] Error 1
make[5]: Leaving directory `/home/steve/audacity/lib-src/redland/raptor/src'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/steve/audacity/lib-src/redland/raptor/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/steve/audacity/lib-src/redland/raptor'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/steve/audacity/lib-src/redland'
make[1]: *** [redland-recursive] Error 2
make[1]: Leaving directory `/home/steve/audacity/lib-src'
make: *** [audacity] Error 2

Anyone got any ideas what’s wrong and what I can do about it?



[EDIT]
I’ve had another couple of goes on another machine - this machine will definitely build Audacity 1.3.5 perfectly, but no go with Audacity 1.3.6

I can post the output from the terminal if that helps.

Is it me or does the 1.3.6 code just not work?

Hi

You may need extra options so that the new directories added to CVS for 1.3.6 get added to your local tree. See:
http://n2.nabble.com/Re%3A-Fwd%3A-Eee-compilation-td1121576.html

As another alternative you could try configure --without all the new libraries

liblrdf
libscorealign
portsmf
raptor
rasqal
slv2

This is not expert advice though. You could always write to audacity-devel if you really get stuck.

Gale