Error Code 9997

Quickly, I’d like to point out, yes, I’ve allowed access to the mic in windows privacy settings. That does not fix this problem.
Using Audacity 2.3.3
I’m using a Rode NT usb mic. It worked fine on my old computer in Audacity, and I’m currently trying to set it up on a brand new laptop.

I can record in a first track absolutely fine, but when I start trying to record a second track, (with exactly the same sample rate, Stereo, 44100hz, 32-bit float) I get this error message:

Error opening recording device.
Error code: -9997 Invalid sample rate.

Any suggestions?

In the Windows Sound settings, set both the recording device and the playback device that you are using to a sample rate of 44100, then start (or restart) Audacity. (Check that the settings in the Windows Sound settings stick - sometimes Windows reverts them to different settings).

I’m a beginner myself but let me put my two cents in as I am Also trying to navigate issues (Windows 10)

Correct,as you stated you must allow microphone access In privacy settings
second, check the recording settings Within Windows (my driver is Realtek)
on my particular laptop there is a record setting for microphone and stereo mix
Unless you’re familiar with zipping in and out of menus these settings can be buried and tricky to find the first time.
Additionally my laptop only has one port that’s a combination microphone and headset which I am finding to be problematic As an interface with audacity
As per recommendations I may consider an external device.

Hi thanks, so I’ve located this setting and it does appear to be the problem, but the option is greyed out, so I’m unable to change it. Any idea how to get round this?

Unfortunately, Microsoft keep making it more difficult to make these settings. I think the information on this page is up to date: