ERROR -9997 invalid sample rate [SOLVED]

Running Windows 10 & Audacity 2.3, but cannot get WASAPI to work. Everything shows up correctly on teh mixer, but when I hit RECORD, I get the ERROR MESSAGE :frowning:. I’ve spent hours and hours reading all I can find on this subject, changing settings back and forth, etc., but am STUCK now.
Can someone give me some help with this? Thanks!

What is the full and exact error message?
What exactly are you trying to do?

Hi Steve,
Am trying to record the sound off of youtube vids like i have been doing for years now with Audacity. I’m guessing that the latest windows update, or something, unchecked something somewhere along the line. I’ve tried changing the sample rate (in three places) to 48000, and then back to 41000, but that doesn’t help a bit.
Error message is - “Error Opening Recording Device. Error Code: -9997. Invalid sample rate.”
Windows 10 PRO 1809.

OK, all, I was able to FINALLY get Audacity working correctly to record audio via my PC, after reinstalling the Realtek High Definition Audio Manager. The “Realtek” was missing in name from the High Definition Audio Device, so am thinking that during the latest Windows Update, that the Realtek drivers vanished in favor of Windows versions, but after the re-installation, the WASAPI feature is functioning perfectly now.

Thank you for the update.
I have closed this topic as “solved”.