Equalizer malfunctioning

I have been working on a project for awhile and all was going well. I needed to add another audio clip into the middle of the already-edited portion, so I imported and started editing the new track. It sounded a bit echo-y, so I pulled up the equalizer to change it to the AMradio preset which is what fixed the sound on the track I had already edited. This time though, when I clicked AMradio, it refused to change, and stayed instead on “unnamed” every time I tried to change it. I tried clicking “Save/manage curves” and choosing AMradio, the curve changed and it showed that AMradio was selected, but the track still sounded the same. Last time while editing the other track, I only had to choose AMradio directly from the normal, obvious preset list next to “Select Curve”.

The Equalization effect is a bit buggy at the moment when in the “Graphic Eq” mode is selected.
Select “Draw” as the “Eq Type”, then you should be able to select any of the presets.

It seems to be worse in 2.1.3 alpha
I’ve got no problem reaching and choosing the presets with keystrokes (although a bit confusing at times) but the dB sliders of the graphical mode are unreachable. The former workaround of switching to draw and back to graphic works no longer.
I always thought that equalization was a core functionality of audio editors. :wink:


As far as I’m aware, there has been one small bug fix since 2.1.2, and no further regressions. If you have noticed new bugs since 2.1.2 Robert, please report them on QA, or start a new forum topic so that it can be logged on the bug tracker.

It’s certainly an important effect for very many audio editing tasks.
Unfortunately the effect had become overly complicated over the years, and then after two major updates to Audacity the effect fell apart. It was patched up so as not to hold up the 2.1.2 release, but I think what it really needs is to be rewritten from scratch. That’s quite a big job and we have limited resources.

Can you give steps to reproduce, Robert?

2.1.3-alpha seems to be the same as 2.1.2. After selecting Graphic Mode, one SHIFT + TAB puts you in the final graphic slider, announced as the 20 kHz slider.


I land on the min dB slider (after pressing alt-d, alt-g, shift-tab) and am where I’ve started after 14 Shift-Tabs.
It’s not unlikely that an update of NVDA has some impact as well.
(Update: Same for WindowEyes 9.5.3)
The interpolation combo isn’t reachable either.


Alt + G then Tab (once) should get you there.

Nope, it gets me to linear frequency scale. -sigh-

The state of the control is “Invisible” in addition to “collapsed” and “Focusable” which are both normal.

“Linear frequency scale” is only in “Draw” mode, not in “Graphic” mode.
“Interpolation” is only in “Graphic” mode and not in “Draw” mode.

I’ve just checked the latest nightly build, and “Alt +G” does switch to “Graphic” mode, and then “Tab” does go to “interpolation”.
It would appear that “Alt + G” is not working correctly on your machine. Could it be set as a global shortcut for some other application?

I don’t think so. The messages are correct after pressing alt-d or alt-g, namely “Draw radio button checked” or “graphic…” respectively.
That’s certainly weird.

Your getting caught by a bug in the mode switching.
The bug: When Equalization launches, it always displays the Draw mode GUI regardless of which mode it is actually in. So if you last used Equalization in Graphic mode, then when you next open Equalization the “Graphic mode” radio button will be selected, but the displayed GUI is the Draw mode GUI. Clicking on the Graphic mode radio button does nothing in this case because it is already selected. To change to the Graphic mode GUI you need to switch to Draw mode, then back to Graphic mode.

(This bug is also present in 2.1.2)

So the full key sequence to open Equalization and access the interpolation control will be (starting with Alt + c to open the Effect menu:
alt + c
alt + d
alt + g

I know that Steve, that was always my workaround but the forth and back switching does not work any longer, the effect seems to be “frozen” in the draw layout, at least my screen reader sees it like that. In other words, there are no accessible state changes fired (Notify_event).
Normally, I would suspect my custom-tailored addon to be the culprit but that’s not possible with the alternative screen reader exposing the same behaviour.

I tested before writing my last post, with a very recent nightly on Windows XP and NVDA screen reader, and it works for me. I also tested with Audacity 2.1.2 and the behaviour was identical.

Perhaps, there’s another application interfering (e.g. the anti-virus program, or rather its window).
Although you’re on XP and I’m on Seven, I don’t think that this makes a difference.
We’ll see.

The keyboard steps Steve wrote out work fine in Windows 10 too. I have not updated NVDA in a while. I have version “2015.3”.


David has just committed a fix for my problem.
Thx from here.