Equalization preset curves dissapear


I’m using Audacity 2.0.3 from source on Linux Mint 14.1 Cinnamon.

I made some presets in the Equalization effect. When I have used a preset and then close the effect window and then use any of the effects from the “plugin 1-xx” (in my case 1-15) menu and then want to use the EQ again on another track all presets are flattened. Including the pre-installed curves.
When I restart Audacity again they are back as normal until I use one of the effects on the extra menu again.

Anyone have an idea on what’s is happening?


I think there is a bug here (it’s been reported on Windows, too) but it is not reproducible.

Do you have to use another effect to make it happen, or just open Equalization again?

Can you try quitting Audacity then renaming EQCurves.xml and EQBackup.xml in ~/.audacity-data/ to something else (note that .audacity-data is a hidden folder). Audacity should then use its default curves in EQDefaultCurves.xml in ~/.audacity-data/ or failing that in /usr/local/share/audacity (where a self-compiled Audacity is installed).

If then naming EQCurves.xml and EQBackup.xml back to their original names recreates the corruption, can you please attach those files to your reply (see https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1 for how to do that).

If those files contain custom presets that you need you could try adding them to EQDefaultCurves.xml (keeping the same xml syntax).



Hi Gale!

Thanks for answering.
I tried some different ways to reproduce the problem:

  1. I have to run an effect from the extra plug-ins, like the Chris dynamic compressor, to make the EQ go flat.
  2. I do not have to have run the EQ first, it is enough to open Audacity run an effect and the EQ-curves is flat when you open the Equalization.
  3. If I restart Audacity the curves are back.
  4. I did delete the EQCurves.xml and EQBackup.xml files and then started Audacity and imported my presets from a saved preset xml-file. The bug still remained.
  5. I copied the presets into the EQDefaultCurves.xml. The bug still was there.
  6. If I look at the EQCurves.xml file the points are still there even if the curve is flat in Audacity.
  7. However, if I open the Equalization after have run e.g the Chris dyn comp. and the curve is flat and then press OK, the point values in the EQCurves.xml files are gone. Then they are still flat after I have restarted Audacity.
  8. If I delete the EQCurves.xml and EQBackup.xml then open Audacity and first run e.g the chris dyn comp effect then open the Equalization all the curves are flat and there are no EQCurves.xml and EQBackup.xml in the .audacity-data folder but an empty EQCurves.xml is crated when I close Audacity.

Maybe the following can help to track the bug:
I have made chains with Chris dyn comp. in it. When I have run this chain and then restart Audacity the presets of the compressor (the ratio, hardness and max amplitude) have falled back to 0. Not in the parameter text line when you edit chains and dubbel click the chis dyn comp. effect in the chain. Nor in the text file for the chain in the Chain folder in .audacity-data. Only if you press change parameters and open the effect settings.

I attach some files:
EQCurves_after cancel.xml is produced after have run an EQ then the chris dyn comp. then open Equalization but pressed cancel.
EQCurves_after OK.xml is produced after have run an EQ then the chris dyn comp. then open Equalization but pressed OK

I did not get any EQBackup.xml file now, I do not now why. I had one before.

EQCurves_after OK.xml (404 Bytes)
EQCurves_after cancel.xml (6 KB)

Thanks for the files and details but I cannot reproduce the problem on Ubuntu 64-bit where running Chris’ Compressor flattens the EQ curves (whether the Chris effect is in a Chain or not).

I see you have

at the bottom of your EQCurves.xml file (underneath ).

Did you ever edit EQCurves.xml yourself file in a text editor?

And are you running Audacity in German, hence the “namnlös”?

Extra “unnamed” curves at the bottom of the curves list is a symptom of the problem. Apart from that, there seems to be no irregularity in the “EQCurves_after Cancel” file which you attached.

If you quit Audacity, then delete EQCurves.xml, EQBackup.xml and audacity.cfg from ~/.audacity-data, delete EQCurves.xml from /usr/local/share/audacity, then paste the attached into ~/.audacity-data, does it stop the problem happening? That attached EQCurves.xml file is Audacity’s default file generated by OK’ing Equalization when EQCurves.xml does not exist anywhere, with your two “SpeakEnhance” curves pasted in at the top after the first line (the paste was done while Audacity was closed).

Try that without importing further curves.

If that works until you import further curves, please attach the .xml files that you are importing.

I don’t really know what you are saying about the Chris’s Compressor parameters. The parameters when you open the effect from the menu are reverted to default with each session. The parameters that you set for the effect in the Chain should be remembered across sessions.

Changing the parameters in the Effect Menu should not change the parameters in the Chain; even accessing the effect parameters in the Chain will modify the settings in the menu (for that session in the case of Nyquist effects). It’s a known problem with some effects.

EQCurves.xml (5.97 KB)

Thanks for taking your time Gale!

The namnlös is added when I open Audacity Equalization I have a Swedish language set. (I change to English but there was no difference except no namnlös is added)
I tried your suggestions.

  1. I deleted the EQCurves.xml, EQBackup.xml and audacity.cfg from ~/.audacity-data
  2. I deleted the EQDefaultCurves.xml from /usr/share/audacity (which is where my audacity remains)
  3. I copied the attached file in ~/.audacity-data.

No differens, it remained with the same bug.

I tried purging Audacity and took away all entries I found then install it again.
I did not import or make any new EQ curves nor did I installed new nyquist effects but still the same bug exists.

I might try installing the 2.0.1 instead and see if it still exist.
Or maybe I should try the ppa 2.0.4?


So if you delete all curve files except EQDefaultCurves.xml in ~/.audacity-data, then:

  1. launch Audacity (so you are only using the default curves set)
  2. run an effect other than EQ
  3. run EQ
  4. choose a shipped preset like AM Radio (but don’t modify it)
  5. run EQ with that preset
  6. reopen EQ

is the AM Radio curve flattened? Or has EQ gone back to a flat “unnamed” choice, but the “AM Radio” curve is still as it should be? Or something else?

No significant code changes have been made to EQ since 2.0.3 release on January 21st. See here for the changeset:
http://tinyurl.com/cnp5w5y .

If you could compile the 2.0.2 tarball http://audacity.googlecode.com/files/audacity-minsrc-2.0.2.tar.bz2 and see if the problem occurs there, it might help. People who have reported problems on Windows have said 2.0.2 is not affected.

Or if you don’t mind using svn (install it if you don’t have it), you could checkout and compile revision 12045, that is the one before r12046 which could perhaps be something to do with it.

Here is how to do that:

svn checkout -r 12045 http://audacity.googlecode.com/svn/audacity-src/trunk/ audacity-read-only

Of or course just remove

mCurves.Add( _("unnamed") ); // we always need a default curve to use

from lines 1036-7 of /src/effects/Equalization.cpp and recompile. I still don’t quite see how that is relevant, unless you are getting a warning “Error Loading EQ Curves” - do you ever see that?


Hi Gale,
If I do as you list above the AM curve and all other curves are flattened. This only happens though if you use and effect from the “1-xx” menu like “High pass” not from the other effects like the Leveller.

I tried before to compile but it did not work out as well so I installed it from package manager instead. Now I have installed the beta 2.0.4. I might try the compiling again some time.

Thanks for the help! I hope that the bug will be solved some time.


Not much to offer I’m afraid, but I’ve been following this topic and I can’t reproduce the problem either (I’m on 32 bit Debian). Not only that, but I can’t see any reason why running a Nyquist effect (such as “High Pass” or Chris’s Compressor) should have any affect on the Equalization settings.
Clutching for straws: Do you have the standalone version of Nyquist installed?

A possible clue: “Shrimp Sandwich”.
“Räksmörgås” is a popular word for testing Swedish translations because it contains the three most common Swedish umlaut-characters (and it translates as “Shrimp Sandwich”).
It appears that in some circumstances, the presence of a non-Unicode character in audacty.cfg can cause settings to be lost.
Also, “Nyquist” (the type of plug-in that is triggering this issue) is not Unicode aware - it uses ANSI.

I’m not sure what this means yet, or where to go from here, but my current suspicion is that a non-Unicode character somewhere could be triggering this issue.
I’ll think about it…

How and where did you install Chris’s Compressor?
Have you manually installed any other plug-ins?

Thanks, both. Jojje said the problem still existed when running Audacity in English, though it’s possible file paths or device names with Swedish characters might still be added to audacity.cfg even if Audacity ran in English.

Jojje, if you are still able to try 2.0.2 in some way, please do. Please delete EQCurves.xml, EQBackup.xml, EQDefaultCurves.xml and audacity.cfg before starting Audacity. If the problem does not occur in 2.0.2, then we have at least narrowed the issue down to a time range.

EQDefaultCurves.xml should have been in /usr/local/share/audacity if you had self-compiled (and also installed) 2.0.3 as I understood. If you have not already done so, you could perhaps check if you have EQ*.xml files in other places that could be confusing Audacity.



Thanks all for suggestions!

  1. I have no stand alone Nyquist installed.

  2. I have deleted the audacity.cfg and Eq*.xml files and restarted audacity several times without any effect. Also purged and installed audacity several times.

  3. I downloaded Chris Compressor from “audacity to podcast blog” and put it in the /usr/share/audacity/plug-ins folder.

  4. I have also installed the noise gate nyquist plug in.

  5. But the last time I installed audacity I did not install any new Nyquist plug-in but the bug was present with a fresh install with no new EQCurves added. All curves in the EQ was flat after having used e.g the High pass. Note that as I have said before that if you press cancel and reopen audacity the curves are back (as in my attached file, the 10/3, EQCurves_after cancel shows) also with the audacity open the xml files look ok if you open it. If you press OK the EQ curves are flat when you reopen audacity and the xml file are empty except fore the names (as the attached file EQCures_after Ok shows).

  6. I do have backups of my pre-sets EQCurves in a folder. I tested to take those away from the computer. But the bug remained.

  7. I tried to compile the 2.02 but did not manage.
    Got this message after ./configure

configure: error: in `/home/jojje/Hämtningar/audacity-src-2.0.2’:
configure: error: C++ preprocessor “/lib/cpp” fails sanity check


I’m not sure how a self-compiled version is finding Chris’ plug-in there. With a default ./configure, self-compiled Audacity should not be looking in /usr/share/audacity/plug-ins, but in /usr/local/share/audacity/plug-ins.

Did you actually compile 2.0.3 before, or install a package of Audacity? I assumed you compiled when you said you were using “sources”.

For the error, you’ll need to look at the configure log for exact clues, but I guess something is missing that needs to be installed - quite typical of Linux Mint. Please look at these search results for some clues.

When self-compiling Audacity it is best to first uninstall any Audacity packages. Before doing that I recommend you create a folder called “.audacity-files” in your home directory, then create a sub-folder called “plug-ins” inside that (no quotes in either of those names). You can then move all your added .ny plug-ins from /usr/share/audacity/plug-ins to ~/.audacity-files/plug-ins. Please do that even if you have not installed an Audacity package.

You can use these steps to compile Audacity if you get into difficulty. These should ensure you get all the requried -dev packages of dependent libraries (though you may still have to install extra packages as indicated by the output of sudo apt-get build-dep audacity.

Finally can you please run Audacity in English and check if audacity.cfg and any EQ* files have any letters other than Latin a - z or A - Z. If necessary, import and export to specially created folders that only have numbers or Latin characters in the complete path to the folder. If there are no Swedish characters in those files, we may be able to exclude that as a theory.

Thanks for your help.


A bug has been opened at http://bugzilla.audacityteam.org/show_bug.cgi?id=627 for problems when explicitly using Equalization in “Graphic EQ” mode (as opposed to “Draw Curves” mode). +

EQ curves are corrupted after switching from Graphic mode to Draw Curves then back to Graphic, or if working in Graphic mode, modifying the sliders then reopening Equalization.

Does this explain any of your issues?

Do your issues go away if you only use Draw Curves (which a fresh audacity.cfg will start from)?