Enormous file sizes

I’m a long time Audacity user and just upgraded from version 2.x to 3.0. I record a radio show in 28 minute segments as two track/stereo files set to 44100Hz/16-bit that would normally be around 570 MB each in version 2.x.

I just recorded my first show using version 3.0 and the .aup3 file sizes range from 1.85 GB up to 2.13 GB. I’m not sure why either would be a different size (as they are of identical length & quality), much less be more than triple the size of my 2.x files. I had a friend check this out and they are also getting huge file sizes. Anyone else experiencing this? I’m on Windows 10.

Have you checked the file sizes after you close the project?

As an experiment I created a project in 2.4.2 that is exactly 30 minutes long, one stereo track, at 16-bit/44.1k quality. The .aup file is 50 KB and the _data folder is 325 MB. The exact same project saved as an .aup3 files is 326 MB.

– Bill

Thanks, Bill. I tried opening a 2.x file in 3.0 and saving it and the file size was correct. It appears that version 3.0 defaulted to 32-bit float instead of the 16-bit PCM sample format I was used to using. That’s what’s displaying in those 3.0 recordings track info: “Stereo, 44100Hz 32-bit float”

Strangely, when I open one of the new 3.0 files and change the format to 16-bit PCM and save, the file stays the same 1.85 GB. Only after I Save as… with a different file name is the file size smaller.

I’ll consider this issue resolved, but I wonder why my default user settings (such as sample format that drastically impact storage space) weren’t retained after upgrading.

Perhaps I’m not understanding your exact steps. This is what I get.

With Quality prefs set to 32-bit I import some audio and save the project, then close it.
I re-open the project and set the Quality prefs to 16-bit. I do Save As and save it with a different name. The file size does not change significantly. Changing the Quality prefs does not change the track format.

I re-open the 32-bit project and use the Track drop-down menu to change the track format to 16-bit. The track info is updated. I Save the project. This time the file size is reduced by about one half. Changing the track format and saving does change the file size - no Save As required.

– Bill

So, I recorded another show yesterday using a sample format of 16-bit and a sample rate of 41000Hz. I record my show live directly into Audacity as three separate 28-minute segments consisting of a single stereo track. The files are 626 MB, 872 MB, and 1.03 GB respectively. Much smaller than when the default format was set to 32-bit and the first segment is much closer to what I’m expecting. I don’t understand the discrepancy with the file sizes as all segments are recorded the exact same way and are normalized to -2.0dB before exporting. No importing audio files or multiple tracks. Just a single stereo track.

I honestly wouldn’t be posting here except that the v3.0 release notes explicitly mention that file sizes should be more or less the same as in v2.0. I can’t say that’s been my experience.

Again, I can’t reproduce this. Tell me if my understanding of your process is correct.

  1. Record a 28-minute segment into an Audacity project. Edit, save and close that project.
  2. Record a second 28-minute segment; edit, save and close.
  3. Record a third 28-minute segment; edit, save and close.

The three projects have files sizes of: 1) 626 MB, 2) 872 MB, 3) 1.03 GB.

You mention exporting. Are you talking about the file sizes of the exported audio files, or the sizes of the Audacity project files?

– Bill

Bill, your summary of my process and the corresponding file sizes are correct.

I do export my show to a 320 MP3 file for uploading to our Enco server, but that has no bearing on what I’m reporting here.

Aside from having to adjust the sample and bit rates back down to 16-bit/41000Hz, I’ve not touched any other setting that were established when v3.0 was installed. Perhaps there are some other prefs that I’ve missed which could affect file size, but I was likely not aware of those the entire time I was using v2.x.

I can also confirm that the default install of the latest version of Audacity (3.0.2) creates MASSIVE .aup3 database files.

It’s to the point where, the .aup3 file representing my one hour radio program is absolutely unwieldy, bringing a quad-core / 16GB RAM / 500GB SSD / i7 Dell workstation to it’s proverbial knees.

I’ll try setting the sample and bit rates back down to 16-bit/41000Hz as noted above; but the default setting is most definitely out to lunch…

Andrew Drouin
The Underground Review
CFUZ 92.9 FM

It is normal and expected that AUP3 files will be big.
In older versions of Audacity, there was a separate “_data” folder that contained the audio data. That folder would grow very large due to the audio data.
In Audacity 3.x, the audio data is included in the AUP3 file.

On closing Audacity, unused “history” data should be automatically removed, and the saved AUP3 file should be approximately:
“4 x sample rate x number of channels” bytes per second of audio.
For example, 1 minute of 44100 Hz stereo audio would be approximately:
4 x 44100 x 2 x 60 = 21168000 = (approx) 21MB
In older versions of Audacity, the _data folder would be about 21 MB, plus a small .AUP file.
In current versions of Audacity, the AUP3 file will be about 21 MB.

Even with the settings dumbed-down as described in the previous missive, during the production of today’s show, the same ‘massive program freezes’ occurred whenever I got about a quarter to half-way into the final edit - where I add DJ chatter / music descriptions between the songs that will air on the radio (final Audacity database).

This happens on both my i5 / 16GB / SSD-based laptop and my i7 / 16gb / SSD-based workstation PC. The exact same effect in both cases.

I’m a 27-year Microsoft Certified Professional, with a bit of history in the IT field… so I run lean / PC clean systems.

In order to get around this weird quirk, I need to export the Audacity file format database into .mp3 file format, and then import it back into Audacity and complete my edits in one shot without hitting ‘save’ (which defaults to the creation of a new 3.x file format database, not an updated .mp3) and then reexport it as an MP3 file for airtime.

Weird, but that works. No matter how large of an [MP3] it creates at any point, Audacity is good with it ~ no wierdness.

The flakiness with the default Audacity file format appears to begin at about 1.5GB database file size.

Andrew Drouin

That’s interesting.

Two things:

  1. With that workaround it would be better to export as WAV in the intermediate step rather than MP3. Encoding to MP3 will unnecessarily reduce the sound quality.

  2. Before a project is saved, Audacity is writing data to the Audacity temp file. The location of that temp file can be seen in
    “Edit menu > Preferences > Directories”
    After the project has been saved, Audacity is writing data to wherever the project is saved.

What is the difference between those locations? Why is there not a problem when Audacity is writing to it’s temp folder, yet there is a problem when writing to the folder where the project has been saved?