Enhancing digital piano sound

The digital piano sounds great going in to Audacity, but loses some clarity, punch and space. I’ve tried bumping up the treble a bit with the EQ effect. I’ve also put a bit of verb on it, using ANWIDA soft. But with verb, you reach a point where getting added space means comprising the focus and clarity of the sound. (unless I’m applying it incorrectly - though I’ve tried varying amounts and levels.)

Here’s a track I just wrote and recorded. Any suggestions? Thanks!
http://www.snapdrive.net/files/372235/Score-Walk%20into%20Town.mp3

The recording is quite badly distorted. Somewhere along the line something is being overdriven. Try turning down the piano volume when you record.

Distorted at 28.5 -29.5 seconds, (and elsewhere). Your treble boost is too much IMO : sounds like you’ve got a hissing gas leak :slight_smile:

I. Cut back the levels to stop the distortion.
2. try a stereo widener rather than boosting treble for more ‘space’ …

The stereo widener I used, (at extreme settings for the purposes of illustration), is second from bottom on this list.

Hey Steve – the interesting thing is, the individual tracks were well within range of distorting. It wasn’t till I exported them into an MP3 that the distortion showed. What’s that?

Thanks, Trebor. I’ll give the stereo widener a shot.

My other general frustration is that when I record and playback, I do it through headphones – Grado SR 125’s. They’ve got incredible detail. However, most speakers that people will be playing back on don’t have that level of detail, so I almost feel like I need to overproduce the tracks in order to get them to pop for the average speakers.

You’re adding sounds together - when you add things together they get bigger - same thing with adding (mixing) sounds.

You can mix your sounds either by just exporting them (mixes tracks automatically) or using “Mix and Render” (Audacity 1.3) / “Quick Mix” (audacity 1.2).
Mixing the tracks before you export can be useful so that you can check that the mix does not distort.
Before you mix the tracks you may need to reduce the volume of each track. You can reduce the volume of all tracks by the same amount (so preserving the balance between parts) by selecting all (Ctrl+A) then use the Amplify effect and enter a negative amount of amplification.

If your final mix is a bit too quiet, use the Amplify effect again to bring the volume back up.

Exporting as MP3 can cause a slight boost to some peaks, so if you are recording to MP3 it is usually best to leave a little bit of headroom - 1dB is usually sufficient.

My recommendation would be - don’t. It is worth checking that nothing weird happens on cheap/low-fi systems and that the recording sounds generally OK, but if you “over produce” to try and sound better on bad systems then it will sound bad on good systems. Anyone that is happy listening with poor speakers will be accustomed to poor sound and no matter what you do it will never sound fantastic.

Thanks, Steve. I appreciate it your help. I’ll try mix and render and/or the Amplify trick.

I’ve also cut out just a bit of the bottom end on the piano (using the HIgh Pass Filter) so that the piano is less cloudy. It seemed to help. I’ll post the result when I’m done.

You can mix your sounds either by just exporting them (mixes tracks automatically) or using “Mix and Render” (Audacity 1.3) / “Quick Mix” (audacity 1.2).
Mixing the tracks before you export can be useful so that you can check that the mix does not distort.
Before you mix the tracks you may need to reduce the volume of each track. You can reduce the volume of all tracks by the same amount (so preserving the balance between parts) by selecting all (Ctrl+A) then use the Amplify effect and enter a negative amount of amplification.

Here’s the remixed version. I simultaneously reduced the volume on all tracks using the “Amplify” effect. Then, exported it as an MP3. Then took that MP3 and applied the “Normalize” effect. There’s only a slight bit of distortion now. Sometimes the piano sounds slightly distorted. However, when I recorded the original piano/key’s track, it showed no distortion areas. Hmnmm. Anyway, the overall mix’s distortion is better now. http://www.snapdrive.net/files/372235/Score-Walk%20into%20Town-remixed.mp3

That’s a lot better isn’t it. As you say, there is still a bit of distortion, for example at 15 to 16 seconds. The level of the mix at this point is sufficiently below 0dB so I suspect that the piano track was recorded a little too loud and was distorted before you got to the stage of mixing.

Converting to MP3 should ideally be left to the very last step of the production process. The MP3 format is what is called a “lossy compression” format - that means that the file size is reduced not only by “squashing” up the data, but by throwing away some of the data - as a consequence there is always a little bit of sound quality loss when you encode as MP3. Opening and MP3, editing it and exporting again as an MP3 increases the quality loss a little more - the quality loss is cumulative. Better is to keep in an uncompressed format (such as WAV) until the final export.

You say Normalize but you don’t say to what setting.

Sorry IMO there are far more instances of distortion on this remix than in the original, the level of the piano is too high.


I’m not sure if this is relevant but I’m using Audacity 1.3.11 (on windows) and I’ve noticed that previews of effects are not accurate if the sample rate is not 44100, e.g. the preview of equalization on a 22050Hz track sounds completely different to when the equalization is applied, (the applied effect is about an octave deeper than it sounds on the preview)*.

Your mp3s are 48000, maybe you could try 44100.

If there is an Audacity bug relating to tracks with sample rates other than 44100 this could explain why your track sounds OK but when saved the equalization and levels change, (becoming distorted and trebly).


[ * maybe I should send in a bug report. ]

Great advice, Steve. I really appreciate it. I’ll try keeping it in WAV until I export to MP3.